Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Tell us which business and trade publications you read most regularly: RESPOND NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
deshania
Contributor II
Contributor II

Qlik Sense Connecting to IBM DB2

Hi,

I'm currently using Qlik Sense Desktop 3.2 and have a problem in connecting to DB2 database. I am able to connect to one DB2 database (DB2/Linux 10.5.0.1) but I am unable to connect to another DB2 Database (DB2/Linux 10.5.0.3). The Qlik ODBC Connector in use is 1.2.1.


When I try to connect to DB2 Database (DB2/Linux 10.5.0.3) with the correct username and password I get the attached error. I am able to connect to this database via a database tool using the same credentials, but not via Qlik Sense. The default time out is set to 60. I have tried by increasing the connection time out and still no result. If anyone has any idea why this is happening can someone help me or guide me?


Thank you.

1 Solution

Accepted Solutions
agigliotti
Partner - Master III
Partner - Master III

did you try using the native ODBC driver of DB2 ?

View solution in original post

5 Replies
agigliotti
Partner - Master III
Partner - Master III

did you try using the native ODBC driver of DB2 ?

deshania
Contributor II
Contributor II
Author

Hi Andrea,

The Native ODBC Driver of DB2 did help. Thank you!

The following links also came in useful. Hence I am posting them for someone who might need them

IBM Knowledge Center

Using the DB2 ODBC Driver with unixODBC

michal_durica
Contributor III
Contributor III

Hi guys,

I have the same problem. Can you please explain me what does Native ODBC Driver means?

Should I use ODBC connector or IBM DB2 connector?

Thanks for help

Michal

deshania
Contributor II
Contributor II
Author

Hi Michal,

Use the IBM DB2 ODBC Driver.

Nasar
Contributor
Contributor

Hi Deshania,

Can you please share the link where we can download IBM DB2 ODBC Drivers?

We are struggling to find the suitable drivers that needs to be installed on Qliksense side.