Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Save the Date: QlikWorld Online, June 24-25, 2020. Free global virtual event for data integration and data analytic gurus. Register Today
Highlighted
New Contributor II

Qlik Sense Dasktop Calculation Timed Out error

Calculation Timed Out

Hi everyone!

I'm using Qlik Sense Desktop and there is a table the computer tries to render with as a result a calculation timed out error. It's a table cointaing some formulas as the others but it gives me the error previously specified. Is there a way to change the timeout before giving the error so I can get the table visualized in Qlik Sense? I have read you can change the settings in the Settings.ini file that at the beginning shows only

[Settings 7]

in the file. Does someone know which parametersw to add to this file or another way to solve the problem?

Thank you. Regards

 

1 Solution

Accepted Solutions
Highlighted
Valued Contributor II

Re: Qlik Sense Desktop Calculation Timed Out error

in settings.ini as a new row

replace NN with the number of seconds you want; e.g. for 120 seconds:

ObjectTimeLimitSec=120

 

 

View solution in original post

6 Replies
Highlighted
Valued Contributor II

Re: Qlik Sense Dasktop Calculation Timed Out error

ObjectTimeLimitSec=NN

With NN being the number of seconds

Before playing around with it I would review the calculations; unless they are really complex, there is probably something wrong with them if Sense times out

Highlighted
Partner
Partner

Re: Qlik Sense Dasktop Calculation Timed Out error

also, try to load datas with limit rows in debug mode and check your chart.

Maybe there are some loosen tables and you try to calculate them together in one chart.

Also, try to implement as much logic in your data model as possible so the expression is simple.

Regards

Highlighted
New Contributor II

Re: Qlik Sense Desktop Calculation Timed Out error

Thank you for the reply.

Referred to this formula

ObjectTimeLimitSec=NN

Where should I put it? In the Settings or the qlikview script?

Thank you.

Regards

Highlighted
Valued Contributor II

Re: Qlik Sense Desktop Calculation Timed Out error

in settings.ini as a new row

replace NN with the number of seconds you want; e.g. for 120 seconds:

ObjectTimeLimitSec=120

 

 

View solution in original post

Highlighted
New Contributor II

Re: Qlik Sense Desktop Calculation Timed Out error

It worked. Thanks

Highlighted
Valued Contributor II

Re: Qlik Sense Desktop Calculation Timed Out error

Please close the thread as solved

Just as a reminder, very long calculations are normally the effect of incorrect/un-optimised data structures or formulas