Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Highlighted
iaingaskin
New Contributor II

Qlik Sense Desktop 3.1 white screen only

Windows 10 v1511 (November edition), fully patched.

.NET 4.6.1

IE 11 and Chrome

My Qlik Sense Desktop v2.2.3.0 stopped functioning this morning with a message that it had expired.

I downloaded the v3.1 executable and carried out the upgrade. Post restart, whenever I start Qlik, all I see is a blank white browser window instead of the hub.

Looking at the chrome-devtool timeline, the only error displayed is:

Failed to clear temp storage: It was determined that certain files are unsafe for access within a Web application, or that too many calls are being made on file resources. SecurityError. Clearing the chrome cache had no effect.

Attempting to browse localhost:4848\hub fails with both IE 11 and Chrome, using IP instead of localhost also fails. Both browsers report page unavailable / no data returned.

Engine log is the only one created, and it just repeats the same lines for each attempted launch:

INFO 20160930T124456.990+0100 7204 8788 Invalid parameter handler set

INFO 20160930T124456.991+0100 7204 8788 ComputerName is **** (no spaces, does contain a hyphen)

INFO 20160930T124457.306+0100 7204 8788 Locale(s) set

INFO 20160930T124457.310+0100 7204 8788 QHeap initialized

INFO 20160930T124457.316+0100 7204 8788 Running in desktop mode

INFO 20160930T124457.316+0100 7204 8788 Initiating server license.

I uninstalled and reinstalled Qlik several times, and also cleared out all of the appdata\local\programs\qlik data in case anything was being left behind from the uninstall. I have a redirected documents folder on a network share, but the Engine log is being successfully written there.

Event Viewer applications log shows a succession of error 300 source: Engine

Additional information is: RestClient HTTP request for url/migrate/ping failed with error code 12029 (source: 5)

A second workstation has also been upgraded and is displaying the same behavior.

My best guess at the moment is that the engine is failing and the browser(s) can't connect. Can anyone offer a solution please?

1 Solution

Accepted Solutions
iaingaskin
New Contributor II

Re: Qlik Sense Desktop 3.1 white screen only

My boss has identified the solution.

In the configuration file C:\Users\%user%\AppData\Local\Programs\Qlik\Sense\services.conf

Change the line:

LogPath="${HOMEDRIVE}${HOMEPATH}\Documents\Qlik\Sense\Log"

To an absolute path (i.e. LogPath="C:\Users\JoeBloggs\Documents\Qlik\Sense\Log")

Qlik sense 3.1 then functions correctly for us.

10 Replies
rittermd
Honored Contributor

Re: Qlik Sense Desktop 3.1 white screen only

Is it possible that it doesn't like your computer name based on the entries you showed?  The older version might not have cared about that. 

rohitk1609
Valued Contributor II

Re: Qlik Sense Desktop 3.1 white screen only

Hi Lain,

The issue is Qlik Sense 3.0 needs network connectivity to run , No matter it is Intranet or Internet.So,

What we need to do , Create a Loop Back Adapter which makes Qlik Sense 3.0 always connect to network no matter you are in any network or not , But Qlik Sense 3.0  will work fine.

Steps are below to create Loop Back Adapter:

Run => write command hdwwiz => advanced => Network Adapter => Microsoft => MS KM TST Loop Back Adapter => Next and Done.

Qlik Sense will work always with network or without network

Please mark the appropriate replies as CORRECT / HELPFUL so our team and other members know that your question(s) has been answered to your satisfaction.

Rohit Kumar

Partner
Partner

Re: Qlik Sense Desktop 3.1 white screen only

Hi Iain,

I had a similar issue when I upgraded to 3.0 in July.  Installing the 3.0.2 service release fixed my problem. The problem is related to the internet connectivity.  At work I'm fine.  At home I'm usually fine until the internet connection become saturated and then I experience this issue.  If you are also trying to use the software offline it is an issue as well.  As I said the 3.0.2 seem to fix my issues allowing me to work offline or in poor internet connectivity situations.

I tried the 3.1 upgrade as an experiment and I'm experiencing the same issue as you have and for me the loop back didn't resolve the issue (maybe I didn't do something correctly in the installing the loop back).  However, uninstalling 3.1 and installing service release 3.0.3 does get it working.  You won't have the features from feature release 3.1 but you do get the features of 3.0 release and you are able to continue using your desktop version.

Good Luck.

Robert Stickle

iaingaskin
New Contributor II

Re: Qlik Sense Desktop 3.1 white screen only

Thanks for the reply Rohit. The machines in question already had both Intranet and Internet connectivity (the latter via a firewall). However, I tried your solution and unfortunately the symptoms were the same.

iaingaskin
New Contributor II

Re: Qlik Sense Desktop 3.1 white screen only

After a bit more digging in the forums I note that someone with almost identical symptoms was able to fix their issue by downgrading to .NET 4.5.2, and stated that 4.6.1 is not supported.

Having tried it with both 4.6.1 (default for Win 10 v1511 - and v2.2.3.0 worked with this) and 4.6.2 (default for Win10 anniversary edition), I still cannot get v3.1 working.

.NET 4.5.2 is not listed by MS as compatible with Win10.

Is this a known problem that Qlik are working on, or am I barking up the wrong tree?

rohitk1609
Valued Contributor II

Re: Qlik Sense Desktop 3.1 white screen only

Hi lain ,

I don't think version of .net framework have any issue . It can happen by your user account or your exe file has been broken . Try to do fresh download an try a clean install. Sometimes registry file gets broken. Please be sure you are not upgrading Qlik sense if yes there are some things need to take care . Better is do a fresh installation.

iaingaskin
New Contributor II

Re: Qlik Sense Desktop 3.1 white screen only

My boss has identified the solution.

In the configuration file C:\Users\%user%\AppData\Local\Programs\Qlik\Sense\services.conf

Change the line:

LogPath="${HOMEDRIVE}${HOMEPATH}\Documents\Qlik\Sense\Log"

To an absolute path (i.e. LogPath="C:\Users\JoeBloggs\Documents\Qlik\Sense\Log")

Qlik sense 3.1 then functions correctly for us.

Partner
Partner

Re: Qlik Sense Desktop 3.1 white screen only

Thanks! This worked for me!!!

I have to say, that in my case it was a network drive:

"P:\bla\bla\bla\Log" and i had to write "\\server\share\bla\bla\bla\Log" then it worked!

iaingaskin
New Contributor II

Re: Qlik Sense Desktop 3.1 white screen only

Hi Emma,

Always nice to be able to help someone else - particularly after bashing my head on the desk for so long .

In our case the environmental variables Homedrive and Homepath resolve to the root of our network share, which users have no permissions on, hence the problem when Qliksense tries to create the logging directories.

Useful to know that we can use the UNC path if we decide to move the logs. Thanks.