Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Qlik Sense Hub can not be accessed via Ipad

Hi,

I have a Qlik Sense server running, can access the Hub via my desktop machine. Whenever I try to open the Hub on my Ipad, I login successfully and then get a popup stating: "An error occurred" Connection lost. Make sure Qlik Sense is running.....

In QMC, I have added the server name (external, internal ip) to the Whitelist, but to no avail.

On an older Ipad (Version 3), I could access the Hub, but not on a Version 4 Ipad (neither on the internal browser, nor on the Chrome).


Any suggestions?

Thanks,
Martin

26 Replies
Not applicable
Author

Yes it's running 8.0.2.

I can access QMC, but not the Hub

Not applicable
Author

I even can't access my hub on HTTP, or is that not supported at all?

So what's your recommendation on how to access an AWS Instance running QV Sense with an Ipad (where I don't want to buy a certificate)?

Not applicable
Author

I have the same issue ;


Tested on

- iPad 2 iOS 8.1 / iOS 8.0.2

- iPhone5 iOS 8.1 / iOS 8.0.2


jim_chan
Specialist
Specialist

Error 400 Bad Request prompted out after i have login my qlik sense hub. but is working fine as per normal when i login sense hub on my laptop(windows 7 os). and i do not have any certificates yet.

so why am i facing error 400 bad request issue?

holajoel
Partner - Contributor II
Partner - Contributor II

Is there a case open for this with support?  I am seeing the same issue with iOS 8 devices (8.2 12D508)

harvinderjohal
Creator
Creator

Try this:

Step1:

1. Launch the QMC

2. Go to Proxies > Central Proxy > Edit

3. Under Ports, check Allow HTTP

Step2:

(if using version 1.0)  4. Scroll down under Central Proxy to Websocket origin white list

(if using version >= 1.1)  4.  Go to QMC > Virtual Proxies > <>(Default) > Edit > Advanced > Websocket origin white list

5. Add your IP address of the Sense Server machine (ie. 10.1.123.234)

6. Add your machine name of the Sense Server (ie.  WIN-SENSESRV01)

7. For Servers on a domain, add fully qualified domain name (ie.  WIN-SENSESRV01.CUSTOMER.COM)

8. If you added a DNS, add that to the list (ie. SENSEBI.COMPANY.COM)

9. If deployed to a VM, enter the IP of the VM

Apply settings and try connecting.

mjendreck
Contributor
Contributor

Harveys answer fixed our problem (connetion lost to hub with Galaxy Tab 10.1 Android 4.1.2)

Not applicable
Author

Hi,

I try all the settings told by Harvey s, even i install the self signed certificate in the iPad, but still i am not able to access the HUB Through Ipad. Please help.

harvinderjohal
Creator
Creator

As of iOS version 8 and above, untrusted certificates are not allowed.  This means that self-signed certificates such as those Qlik Sense uses out of the box are not sufficient to enable access to the Qlik Sense Hub on iOS devices.

The easiest solution is to utilize the Proxy setup as per above and have users navigate to the server via HTTP and not HTTPS.  **Make sure to have HTTP enabled anyway for if the below doesn't work, you will need an alternate way to get back into the QMC.

NOTE:  If you are unsure about the below or feel you need assistance, do not attempt and contact your sales representative to get help from a Qlik certified partner or Qlik Expert Services.

======

If you must use a trusted certificate, you will need to install your own.  You can get your own certificate, with private key, from a trusted root certificate authority (ie Symantec, GoDaddy, etc...).

Once you have this certificate, you will need to import it into your windows deployment.

Launch the MMC, add the certificates snapin, and import in your certificate to:

1. Current User > Trusted Root Certification Authorities > Certificates

2. Local Computer > Trusted Root Certification Authorities > Certificates

3. Local Computer > Personal > Certificates

Double click onto the imported certificate and validate the existence of the private key.  It will say at the bottom of the certificate dialog box from start to end date for when the certificate is valid.  ie. Valid from begin_date to end_date.

Go to the detail tab of the Certificate Dialog box.  Select Thumbnail.  Copy the value.

Open the Sense QMC

Go to Proxies>Central Proxy>Edit.  Select Security for additional properties.  Paste in the value for SSL browser certificate thumbprint (important**  remove the spaces within the pasted value).

Click Apply.

Not applicable
Author

Thanks Harvey will try this.