Qlik Community

Ask a Question

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
cancel
Showing results for 
Search instead for 
Did you mean: 
Creator
Creator

Qlik Sense SSO behind NGINX reverse proxy

My Qlik Sense server is running online on an AWS EC2 instance with a public IP address.  I am using Okta with SAML as a single sign on service. Everything is working fine.

But now I want to remove the public IP address and move the Qlik Sense server to a private subnet behind a NGINX in a public subnet. So the only public endpoint is NGINX. To reach the Qlik Sense server I have to go through NGINX.

I tried to configure NGINX to forward all requests. But it is not working. Lets say my public endpoint is: qlik.server.public. When I am calling qlik.server.puplic/okta/hub I get the Okta Login Screen. And after logging in, I get a screen displaying: Signing in to Qlik Sense... But nothing more. NGINX should pass the requests to qlik.server.local.

Does anybody know ho to configure NGINX to forward SSO SAML Authentication and so on?

Thanks for helping me!

BR

1 Solution

Accepted Solutions
Partner
Partner

check your proxy and virtual proxy settings for load balance on servers.

View solution in original post

4 Replies
Partner
Partner

to investigate deeper i suggest you to take a look at your Qlik Sense server logs files, maybe they can helps to understand what is going on.

Creator
Creator

Now it is running. I forgot to use http_upgrade. I didn't know that there is a websocket connection.

I can login to QMC. But when I am trying to connect to the HUB, I'm getting the following message:

qlikproxy.PNG

Partner
Partner

check your proxy and virtual proxy settings for load balance on servers.

View solution in original post

Creator
Creator

My configured node for load balancer was gone. After adding the node again, everything works fine! Thanks!