Qlik Community

Ask a Question

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Our next Qlik Insider session will cover new key capabilities. Join us August 11th REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
gino_scheppers
Contributor III
Contributor III

Qlik Sense and Webseal - header authentication

Hi,

we are trying to setup Qlik Sense (june 2017 version) in combination with the IBM Security Access Manager (WebSeal).

We want to use header authentication.

Setting up the virtual proxy seems no problem. I'm using static header authentication and I can capture the injected user-id.

In the audit log I get the message that the injected user-id received his session. 'User 'u17532' used 'header' authentication, got session:'

But in the hub I receive  the following error-message: 'the service did not respond or could not process the request.'

tracing the browser I get 500 as result on the get-request /websealauth/api/hub/about.

2017-10-04_11-14-39.png

Our webseal team is trying to setup (with trial and error) the webseal configuration. Is there an example, technical guide, best practice,... available on how to setup a correct webseal-configuration file?

Regards

Gino

2 Replies
balexbyrd
Contributor III
Contributor III

Unfortunately I have nothing to contribute except to join the group of users with the same issues.

I'm on QS Sept 2017 in a multi-node using SAML and getting the same error and blocked at the same spot as you.

See Multi-Node SAML with SSL - Isolate users to Engine nodes for details.

Starting to think it's a bug!

poppypearce
Creator
Creator

Hi Gino,

Please let me know if you were able to resolve the issue. we are also facing the same.

Regards,

Poppy