Qlik Community

Ask a Question

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Our May 2021 end-to-end product release from Data Integration to Data Analytics is out! READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
stvegerton
Creator III
Creator III

Qlik Sense iframes in Salesforce on Mobile Device

We're having problems getting Qlik Sense iframes imbedded in Salesforce to work. Here is our authentication flow. What are our options? Thanks, Steve

SFDC Qlik Sense Iframe authentication failure.JPG

1 Solution

Accepted Solutions
stvegerton
Creator III
Creator III
Author

Here's what ended up working for us. We used something that SecureAuth refers to as a "digital fingerprint" on our mobile devices. This allowed us to set different credential expiry controls for QS vs. the SF1 app. Our policy for QS is 30 days and SF1 does not expire.

final auth flow.JPG

View solution in original post

8 Replies
Not applicable

Steve, have you watched these videos on setting up SFDC SAML with Qlik Sense:

Video Link : 3605

From the looks of it you have, but iframes are still not working.  Iframes in salesforce require https.  It's not clear from the doc above if you are trying to use https.  Given that the iframes are failing, can you take a dev tools screenshot from chrome to display the console messages that may / may not be appearing?

jg

stvegerton
Creator III
Creator III
Author

Thanks Jeff. I've watched the videos, but if I recall, they are geared towards using SF as the identity provider. I'll look again if I'm mistaken.

Just to clarify, Qlik Sense iframes imbedded in Salesforce work perfectly for us on a desktop. But when on a mobile device, our netscaler looks for qliksense.mycmpny.com and appends /mobile/ so it's routed to our SAML virtual proxy. Our SAML virtual proxy works great for going to the hub on a mobile device. But the URL has to be perfect. 

These iframe urls look something like this: https://mycmpny--devpoc.lightning.force.com/one/one.app#eyJjb21wb25lbnREZWYiOiJvbmU6YWxvaGFQYWdlIiwi...

I've never tried chrome on a mobile device for debugging. I'll give it a shot.

Not applicable

Don't know if you can.  So I've done Salesforce1 integration using visualforce pages.  Are you trying to do the same thing?

I have not tried this in new lightning interface.

stvegerton
Creator III
Creator III
Author

We're using Visualforce pages as well. Did your iframes to Qlik sense go to urls other than the hub and work ok on mobile devices? Was Salesforce the identity provider? Thanks, Steve

Not applicable

Yes and yes.  I have used single objects.  What I think is different is your url path insertion at the netscaler.

stvegerton
Creator III
Creator III
Author

Understood. Since the QS SAML virtual proxy requires a prefix for routing, I don't know what our options are to guide these long iframe URLs to the QS SAML virtual proxy.

stvegerton
Creator III
Creator III
Author

Here's what ended up working for us. We used something that SecureAuth refers to as a "digital fingerprint" on our mobile devices. This allowed us to set different credential expiry controls for QS vs. the SF1 app. Our policy for QS is 30 days and SF1 does not expire.

final auth flow.JPG

View solution in original post

bujnakbranislav
Partner
Partner

Steve - I have been testing Qlik Sense Objects embedded into SFDC and came across the same issue. I also watched jg's videos and what I found out was that when I switched the syntax in the VisualForce charts displaed in the SFDC Mobile App.

Here is what I did:

Originally my VF Markup looked like this and it wouldn't display on Mobile App (two things I changes in the iframe syntax

1. I added apex:iframe

2. I changed single ' to double " around the url and it worked on Mobile App in iOS as VF Page, but not as VF Account Page. Waiting for Qlik to help me figure out what's blocking it from displaying on Account Record Page

OLD (only working on PC, not iOS)

<apex: page>

<iframe src='https://.......'></iframe>

</apex:page>

 

NEW (works on PC and iOS)

 

<apex: page>

<apex:iframe src="https://......."></apex:iframe>

</apex:page>