Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Qlik Sense installation failure

Hi,

I'm trying to help somebody getting Qlik Sense Desktop to install on his laptop. So far no success.

Things tried so far

  • Run the installer with the Run as Administrator option
  • Disable antivirus
  • Check that the users document folder is a regular folder and not a shared network drive or something like that
  • Custom install with a different installation location (c:\qlik\sense)
  • Tried both the june2017 release and 3.2 SR4

Things seem to go fine until as custom action involving powershell gets executed. After that fails it looks like a rollback is started. Below a part of the log that seems relevant. The full log is attached. I'd appreciate any help.

MSI (s) (2C:44) [10:38:12:828]: Executing op: ActionStart(Name=WriteIniValues,Description=Writing INI files values File: [1],  Section: [2],  Key: [3], Value: [4],)

MSI (s) (2C:44) [10:38:12:829]: Executing op: ProgressTotal(Total=4,Type=1,ByteEquivalent=13200)

MSI (s) (2C:44) [10:38:12:829]: Executing op: IniFilePath(File=Settings.ini,Folder=C:\Qlik\Sense\Engine\)

MSI (s) (2C:44) [10:38:12:830]: Executing op: IniWriteRemoveValue(Section=Settings 7,Key=StoragePath,Value=C:\Users\Carlo\Documents\Qlik\Sense,Mode=0)

MSI (s) (2C:44) [10:38:12:832]: Executing op: IniWriteRemoveValue(Section=Settings 7,Key=CustomDataPath,Value=C:\Qlik\Sense\Connectors,Mode=0)

MSI (s) (2C:44) [10:38:12:837]: Executing op: IniFilePath(File=services.conf,Folder=C:\Qlik\Sense\)

MSI (s) (2C:44) [10:38:12:837]: Executing op: IniWriteRemoveValue(Section=globals,Key=LogPath,Value="C:\Users\Carlo\Documents\Qlik\Sense\Log",Mode=0)

MSI (s) (2C:44) [10:38:12:841]: Executing op: IniFilePath(File=QlikSenseBrowser.ini,Folder=C:\Qlik\Sense\QlikSenseBrowser\)

MSI (s) (2C:44) [10:38:12:841]: Executing op: IniWriteRemoveValue(Section=General,Key=cloudreg,Value=false,Mode=0)

MSI (s) (2C:44) [10:38:12:844]: Executing op: ActionStart(Name=CA_ConvertToUTF8,,)

MSI (s) (2C:44) [10:38:12:845]: Executing op: CustomActionSchedule(Action=CA_ConvertToUTF8,ActionType=1025,Source=BinaryData,Target=CAQuietExec,CustomActionData="powershell" -NoLogo -NonInteractive -InputFormat None –ExecutionPolicy Unrestricted -Command "if (Test-Path -path 'C:\Qlik\Sense\Engine\Settings.ini') {{ (Get-Content 'C:\Qlik\Sense\Engine\Settings.ini') | Set-Content -Encoding UTF8 -Force 'C:\Qlik\Sense\Engine\Settings.ini'" }})

MSI (s) (2C:20) [10:38:12:849]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI73BE.tmp, Entrypoint: CAQuietExec

MSI (s) (2C:48) [10:38:12:850]: Generating random cookie.

MSI (s) (2C:48) [10:38:12:856]: Created Custom Action Server with PID 6084 (0x17C4).

MSI (s) (2C:50) [10:38:12:943]: Running as a service.

MSI (s) (2C:50) [10:38:12:948]: Hello, I'm your 32bit Impersonated custom action server.

CAQuietExec:  Error 0xc0000142: Command line returned an error.

CAQuietExec:  Error 0xc0000142: QuietExec Failed

CAQuietExec:  Error 0xc0000142: Failed in ExecCommon method

CustomAction CA_ConvertToUTF8 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

MSI (s) (2C:44) [10:38:13:110]: Note: 1: 2265 2:  3: -2147287035

MSI (s) (2C:44) [10:38:13:111]: User policy value 'DisableRollback' is 0

MSI (s) (2C:44) [10:38:13:111]: Machine policy value 'DisableRollback' is 0

Action ended 10:38:13: InstallFinalize. Return value 3.

MSI (s) (2C:44) [10:38:13:260]: Executing op: Header(Signature=1397708873,Version=500,Timestamp=1260737681,LangId=1033,Platform=589824,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=0)

MSI (s) (2C:44) [10:38:13:261]: Executing op: DialogInfo(Type=0,Argument=1033)

MSI (s) (2C:44) [10:38:13:261]: Executing op: DialogInfo(Type=1,Argument=Qlik Sense Desktop)

MSI (s) (2C:44) [10:38:13:262]: Executing op: RollbackInfo(,RollbackAction=Rollback,RollbackDescription=Rolling back action: [1],,CleanupAction=RollbackCleanup,CleanupDescription=Removing backup files File: [1],)

MSI (s) (2C:44) [10:38:13:264]: Executing op: ActionStart(Name=CA_ConvertToUTF8,,)

MSI (s) (2C:44) [10:38:13:264]: Executing op: ProductInfo(ProductKey={907839F0-F050-4C4A-BDF4-2FB2A133A39F},ProductName=Qlik Sense Desktop,PackageName=SenseDesktop.msi,Language=1033,Version=169607170,Assignment=0,ObsoleteArg=0,ProductIcon=Icon_Qlik,,PackageCode={DDB6934C-97B4-4198-9643-F464C328AABA},,,InstanceType=0,LUASetting=0,RemoteURTInstalls=0,ProductDeploymentFlags=2)


talk is cheap, supply exceeds demand
2 Replies
sriramsit
New Contributor

Re: Qlik Sense installation failure

Hi Gysbert,

Is this a 32-bit OS or 64-bit?  I had faced similar problems earlier when I was installing QS on 32-bit laptop.

Sriram S

mkelemen
Contributor III

Re: Qlik Sense installation failure

Hi Gysbert,

try using the -layout to extract the MSI files (sense, demoapps, connectors) and install the files separately.

I have a similar problem - I cannot upgrade the QS on my machine and this works for me. It even works with user documents on network drive.

The reason is probably different in my case but this should work for you as well - it seems that the installer that extracts the 3 MSI files and runs them is failing.

BR,

  Matus