Qlik Community

Ask a Question

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

QlikSense Hub "An error occured - The app you specified could not be found"

Hi All

I've just deployed QlikSense server and I have been working on an App. I came back after lunch and I'm getting this message. I only have two test apps, and I am getting the message on both. I am able to create and work on a new app as usual. I've tried some of the solutions on other forum threads, namely restarting the Virtual Machine and restarting all QlikSense Services. However, the issue persists.

Does anyone have a solution for this?

Thanks,

Will

Qliksense error.PNG

1 Solution

Accepted Solutions
Contributor III
Contributor III

Dear Andrea/All,

Thanks for your suggestion. Upon further digging, I found the file location in which the binary files are stored:

C:\ProgramData\Qlik\Sense\Apps


However, there was only one App here (the newly created App I could open in the OP).


I then checked the Recycle Bin and found that there was an App folder in there. I restored this App Folder, found its location to be C:\QlikShare\App (the QlikShare folder I created during QlikSense Server Intallation), and this contained the binary data files for the apps that did not work.


I copied the entire contents of the App folder (and subfolders) to the new location (C:\ProgramData\Qlik\Sense\Apps) and it all works now.


Thanks for your help. If anyone could explain why the folder location changed (I didn't change it) that would be interesting to know.


Regards,

Will

View solution in original post

4 Replies

May be check this:

In my case I was dealing with Qlik Sense Server, so rules could interfere.

I had disabled the default Security Rule called "CreateApp",

After re-enabling it, I could create the app:

re-enabling default CreateApp rule.PNG

Partner
Partner

I suggest you to check if your app ID file exists on your file system.

I hope it helps.

Contributor III
Contributor III

Dear Bala,

I have checked the CreateApp security rule and this was enabled. My issue is not with Creating apps. It is that I cannot access previously created Apps.

Regards,

Will

Contributor III
Contributor III

Dear Andrea/All,

Thanks for your suggestion. Upon further digging, I found the file location in which the binary files are stored:

C:\ProgramData\Qlik\Sense\Apps


However, there was only one App here (the newly created App I could open in the OP).


I then checked the Recycle Bin and found that there was an App folder in there. I restored this App Folder, found its location to be C:\QlikShare\App (the QlikShare folder I created during QlikSense Server Intallation), and this contained the binary data files for the apps that did not work.


I copied the entire contents of the App folder (and subfolders) to the new location (C:\ProgramData\Qlik\Sense\Apps) and it all works now.


Thanks for your help. If anyone could explain why the folder location changed (I didn't change it) that would be interesting to know.


Regards,

Will

View solution in original post