Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
Showing results for 
Search instead for 
Did you mean: 

QlikSense connect to Microsoft SQL Server


I want to create connection to my MS SQL Server.

1. Using OLE DB Provider for SQL Server, i can create the connection and read the data.


2. Using Qlik ODBC connector, i can not connect to the server with the same information.

odbc.PNG error.PNG

It happens on both Qlik Sense Desktop and Enterprise. I am using April 2018 version and Qlik ODBC Connector package version 4.8.

Do i have to change any input/configuration to use Qlik ODBC connector?



12 Replies

Because Qlik provide 2 ways to connect to MS SQL: OLE DB and ODBC, i just want to make sure both ways can work.

I am learning to use Qlik ODBC for MS SQL and Oracle, start with MS SQL first.

I believe i did something wrong because if it can not be use, why Qlik provide their own ODBC connector.

Former Employee
Former Employee

Quy_Nugen, I was working on a similar issue recently and saw a very similar error while using the Qlik provided SQL Server connection. The issue ended up being the port specified in the SQL Server connection. While reviewing the configuration in SQL Server Configuration Manager, there are lots of options on how to configure the various ways to connect to the database and what port to use. Here is a link to the microsoft site with some information about this for SQL Server 2017:

I was able to connect successfully using the Microsfot SQL Server connection by using the TCP dynamic ports listed on the above page. I spoke with a few other Qlik engineers and consensus was to use the vendor provided connectors as a best practice. I hope this helps you if you are still facing this issue.

Partner - Creator II
Partner - Creator II

The reason that Qlik ODBC Connector fails is that it is using TCP/IP pipes and SQL Server Express, if you didn't enable it, has it turned off by default. do this from SQL Server Configuration Manager