Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Highlighted
shwetapsarda
New Contributor II

QlikSense upgrade- set expression not working properly

We have done upgrade from Qlik Sense 3.1 SR4 to Qlik Sense November 2017 Patch 2 -11.24.4.

In one of the chart, I am showing Rolling last 13 months trending using set expression

sum({<[AsOfDate.Month]=,[AsOfDate.MonthIndex]={">= $(=$(vMaxMonthIndex)-12) <=$(=$(vMaxMonthIndex))"},[Active Flag] ={"A"}> } Exposure )

This was working fine before upgrade.

This expression is not working properly after upgrade. Do I need to change anything in this expression?

Thanks,

Shweta

4 Replies
Digvijay_Singh
Honored Contributor III

Re: QlikSense upgrade- set expression not working properly

Try with single quote here like 'A', may be-

[Active Flag] ={"A"}> }

shwetapsarda
New Contributor II

Re: QlikSense upgrade- set expression not working properly

Thanks,

This is not working. I tried but output is still same.

OmarBenSalem
Esteemed Contributor

Re: QlikSense upgrade- set expression not working properly

try as follow: I'll just eliminate the space btwn >= and $(=$(vMaxMonthIndex)-12)

It should work:

sum({<[AsOfDate.Month]=,[AsOfDate.MonthIndex]={">=$(=$(vMaxMonthIndex)-12) <=$(=$(vMaxMonthIndex))"},[Active Flag] ={"A"}> } Exposure )

if not, try:

sum({<[AsOfDate.Month]=,[AsOfDate.MonthIndex]={">=$(vMaxMonthIndex)-12) <=$(vMaxMonthIndex))"},[Active Flag] ={"A"}> } Exposure )

else, try to put the inside of ur variables directly wihin the set expressions and see what happens.

sometimes, when a variable is defined with a '=' It won't work in a set expression (and vis versa)

shwetapsarda
New Contributor II

Re: QlikSense upgrade- set expression not working properly

Thank you Omar,

I tried all three options you suggested, but nothing is working.

for the second option you suggested, it's not giving me the rolling last 12 months from the selected as of date month.

One more thing to note here-

When I load my expression, first time it gives me all the available months trending.

But when I select the as of date month filter, it gives me rolling last 12 months with required values but all lines are greyed out(not showing colors) as

Community Browser