Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

vigneshvenugopa
New Contributor

Qliksense Load Data - Table not found

Hi,

I'm trying to load a new table(subs_agg), from a existing table(subs_detail) created by connecting to a Hadoop Server.

subs_agg:

Load part_date, sum(total_event_charge) as event_charge, sum(total_subscriptions) as subscriptions

RESIDENT subs_detail

Group By part_date;

But I get the below error:

The following error occurred:

Table 'subs_detail' not found.
Please help me fix this error.
6 Replies
Employee
Employee

Re: Qliksense Load Data - Table not found

Have you already loaded subs_detail successfully ?

vigneshvenugopa
New Contributor

Re: Qliksense Load Data - Table not found

Yes, the table is already being used to creating dashboard.

Employee
Employee

Re: Qliksense Load Data - Table not found

Can you post the output of the load script please ?

lech_miszkiewic
Honored Contributor III

Re: Qliksense Load Data - Table not found

you need to make sure  you load "subs_detail" detail table in qlik script before you create subs_agg table.

Make sure that at the stage where you are trying to use it it is called  "subs_detail". It might be that you rename this table later in script;

Since you are giving us only part which is not working we cant tell you whats wrong. In this case posting whole script would be a lot more helpful.

cheers

Lech

vigneshvenugopa
New Contributor

Re: Qliksense Load Data - Table not found

This is output of the load script, after I load data from Hadoop server.

Started loading data

Connected

subs_details << QueryResult Lines fetched: 92 Creating search index

Search index creation completed successfully

App saved

Finished successfully

0 forced error(s)

0 synthetic key(s)

-------------------------------------------------------------------------

But when I include the script, this is the error I get

Started loading data

The following error occurred:

Table 'subs_details' not found

The error occurred here:

subs_aggr: NOCONCATENATE Load part_date, sum(total_event_charge) as event_charge, sum(total_subscriptions) as subscriptions RESIDENT subs_details Group By part_date

Data has not been loaded. Please correct the error and try loading again.

lech_miszkiewic
Honored Contributor III

Re: Qliksense Load Data - Table not found

Hi,

i am not interseted in output as it does not say everything we need to know, i want to see your whole script before you run it...

cheers

Lech