Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

thi_pham
Contributor

Qliksense desktop 3.0, connection between tables are lost after upgrading

After upgrading Qliksense desktop from 2.1 to 3.0, I tried to open apps created on old version, then Load Data.

Then, I found the data could not be loaded on visualization and on data manager, I found the common field name of tables were changed the name (such as DateID is changed to TableName.DateID), and the connection between tables were broken.

What's wrong or changed introduced in this new version? How to fix or convert old app to work on this new version?

After upgrading, no connection between tables:

Untitled.png

Tags (1)
1 Solution

Accepted Solutions
miguelbraga
Valued Contributor III

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

Forgot to mention this:

If you can't see the video, then I recommend you to drag and drop one bubble to another to creat your desired association. You'll see if you can link one table to another and see for your self the association and you can also rename the key field name.

Hope it helps you

Regards,

MB

7 Replies
miguelbraga
Valued Contributor III

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

Hey there Thi Pham,

See the video bellow, it might help you solve your problem:

Qlik Sense 3.0 - Visual Data Preparation - YouTube

This video explains the new property of Data Visualization Preparation that is very powerful and intuitive in Qlik Sense 3.0.0.0.

Regards,

MB

miguelbraga
Valued Contributor III

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

Forgot to mention this:

If you can't see the video, then I recommend you to drag and drop one bubble to another to creat your desired association. You'll see if you can link one table to another and see for your self the association and you can also rename the key field name.

Hope it helps you

Regards,

MB

undergrinder
Valued Contributor II

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

Hi Thim,

I don't think so that your table connections are lost. Just check the data model viewer.

G.

thi_pham
Contributor

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

Thanks so much, Mr Miguel Braga, I gonna try your suggestion.

Just I think if Qlik has an upgrade, they should support to convert the app to work with new release, if a complex app have many facts, dimensions, just imagine that users have to remember them and drag & drop connections between tables which they haven't seen maybe for a long time.

miguelbraga
Valued Contributor III

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

No worries

If you need some other help please respond and I'll reply you. If my answer is helpful or correct, mark it so that this thread will be closed

Regards and wishes of luck on your work,

MB

thi_pham
Contributor

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

Hi G, the connections were lost cuz the common field names in table were changed (the table names were added to the name like TableName.CommonField), I checked on Data Model viewer. That maybe an error when migrate apps to new version of Qliksense, I guess. Thanks!

undergrinder
Valued Contributor II

Re: Qliksense desktop 3.0, connection between tables are lost after upgrading

Hi Thi,

In this case you can try insert

unqualify *;

At the beginning of the script.

G.

Community Browser