Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Qlik Cloud Maintenance is scheduled between March 27-30. Visit Qlik Cloud Status page for more details.
Showing results for 
Search instead for 
Did you mean: 
Creator II
Creator II

REST connection to Elasticsearch via POST


i'm trying to connect to an Elasticsearch database and read out all documents of an index.

My Qlik Sense version is: June 2017 (soon to be updated).

In Postman the request for this would look like this:


POST /[uri]/_search HTTP/1.1

Host: [host]:9200

Cache-Control: no-cache

Postman-Token: 59ab29c6-755f-4800-b241-55734aed67ad


    "query": {

        "match_all": {}




I tried a GET request a this one worked fine.

This POST request works fine too if i leave out the request body so i guess the error is somewhere in that area.

The funny thing is, that i get no error when i press 'Test connection', the error comes when i want to save the connection.

You can find the error message in the attachment.

For me this look pretty much like a bug in the REST connector.

I tried to leave out the spaces in the request body without success.

Has anybody some advice for me concerning that error message?

Thanks a lot in advance.


0 Replies