Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Read Only Access to specific Application Published in a Stream

QLIK SENSE 2.2

I'm trying to give read only access to a specific application published in a stream.  I have tried several things and what I think should work, but does not. I have created a Security Rule, "SalesStreamAccess" and added that Role to a specific user.  The rule's advanced filter is "Stream_<ID For Stream>, App_<ID for App>".  See Below

Security rule edit - QMC.png

When I preview the rule, for the App and Stream it shows the source user has read only access.  Basically, it looks like it should be working.

PreviewStream.png

PreviewApp.png

So, It previews and looks like it should be functioning, however neither the stream or APP are visible for this user.  Should this be working like I think it should or am I missing something?

Thanks

1 Solution

Accepted Solutions
hadooqlik
Contributor III
Contributor III

Hi Scott,

The Stream_<ID For Stream> rule only grant read access for stream and not for his applications. The rule which allows read everything published in stream is "Stream" (default), so you should do another one more specific for you.


Captura.PNG

I have disabled it for this reason


JuanJo

View solution in original post

6 Replies
gompa786
Creator III
Creator III

Hi Scott,

Also please check whether you have taken care of the below screen shots as well for your particular stream.

first one:

and the next after clicking on the edit:

Sometimes it shows on the Audit but please recheck...

Thanks

Chandra

Not applicable
Author

Thanks so much for the quick response.  While checking your suggestions, I noticed that my new rule was disabled.  I don't know how I overlooked it.  The rule is now working, "sort of".  The "stream" rule that I have allow read access to everything published within the stream, which overrides my rule for just a specific application.  When I disable this "Stream" rule, no sheets are available. 

hadooqlik
Contributor III
Contributor III

Hi Scott,

The Stream_<ID For Stream> rule only grant read access for stream and not for his applications. The rule which allows read everything published in stream is "Stream" (default), so you should do another one more specific for you.


Captura.PNG

I have disabled it for this reason


JuanJo

View solution in original post

Not applicable
Author

Juan, this completely resolved my issue.  I disabled that rule and set up rules for each App in the stream and it works perfectly now.  Thanks

rbpeterson2
Contributor III
Contributor III

This doesn't remove the edit button, however, just forces the user to be prompted with a dialogue window stating that they can duplicate the sheet and not edit the current one ...

Is there a way to just remove the edit button altogether? (and also the snapshot icon?)FastStoneEditor.png

kbush
Contributor II
Contributor II

@hadooqlik - Are you able to provide the additional text from the 'Conditions' script? 

I have a similar problem. I have one app, Widget Sales, within a stream named Retail that has 9 other apps in it. I need to grant a specific user, Joe Person, READ access to only one app, Widget Sales, within the Retail stream. Also, I need to allow 4 other users access to all 10 apps in the Retail stream. Can you help me set up this rule using the information below? 

Stream name - "Retail"

App name - "Widget Sales"

Sheet1 name - "Sales By Store"

Sheet2 name - "Sales By Territory"

User - "Joe Person"