Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Request to Qlik Session Api return Could not create SSL/TLS secure channel.

Hi All

I tried to run this example Configuring IIS for the Qlik Proxy Service API - YouTube‌  + Using the Qlik Proxy Service Session API with IIS - YouTube but I got the following error Could not create SSL/TLS secure channel in this fragment of code.

HttpWebResponse response = (HttpWebResponse)request.GetResponse();

I tried to fix the error adding before the request

ServicePointManager.Expect100Continue = true;

ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;

But that did not resolve the issue.

I have two servers. The first where is installed Qlik QMC and the second where is running an external app to display reports (This is an asp. net web application using 4.0 framework). Both servers have the same certificate (self created not trusted, just to test this example). I did the configurations of the first video to setup the IIS 7.0 and I ran the code of the second video that I downloaded from GitHub - goldbergjeffrey/qssession: A simple asp.net page to test the session api with Qlik Sense En....

Do you know if I am missing something? Maybe it is not working because I am not using QlikClient certificate because I am using an auto created non trusted cert?

Every comments will be appreciate!


1 Reply

Hi Wildo,  Even I was getting the same error.Need to do following steps to resolve this issue.

  1. Open MMC through RUN command.
  2. Install the certificate (.pfx files) to the Personal folder under the Local Machine certificate store of the web server (mmc) .
  3. From the certificates snap-in right click the installed certificate and select Manage Private Keys.
  4. Give Permission for QlikClient Private keys :- Add Application pool of IIS i.e. (Add Group or usernames (e.g. IIS_IUSERS, IUSER)) list and click Apply to access the certificate.

Let me know if this resolves this issue for you.

Best Regards,