Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
See why BI users voted Qlik #1 in 11 categories. GET REPORT
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

Restrict one of the filters on multi KPI

Hi,

I have 2 identical sheets that display several KPIs and a multi KPI. There are also 3 filters on each sheet: district, year and area.

I want to use one sheet to display data according to all filters, that is KPIs for a chosen district,year and area.

The 2nd sheet is the main one, and it displays the data for the whole organization. That is, the same KPIs but  using only 2 of the filters: year and area. In order to give the user the full picture on one page I want to add a multi-KPI or a table to show the data for all districts in the organization.
The chart should be based on the district dimension, but it should always display all the values in this dimension, without filtering.

Is there a way to disable the filter itself for the specific chart? Otherwise it shows only the selected districts and not all of them. 

Labels (1)
1 Solution

Accepted Solutions
Highlighted
Creator II
Creator II

You should include “{<FieldToIgnore>}” in the measure expression to disable / ignore a filter selection for a certain KPI, i.e., sum({<DistrictField>} Sales). This expression will ignore selections from the field DistrictField. If you want to ignore multiple filters, just add an extra dimension field (comma separated). In case you want to ignore all filters, use “{1}”, i.e., sum({1} Sales). 

Hope it helps!

View solution in original post

5 Replies
Highlighted
Creator II
Creator II

You should include “{<FieldToIgnore>}” in the measure expression to disable / ignore a filter selection for a certain KPI, i.e., sum({<DistrictField>} Sales). This expression will ignore selections from the field DistrictField. If you want to ignore multiple filters, just add an extra dimension field (comma separated). In case you want to ignore all filters, use “{1}”, i.e., sum({1} Sales). 

Hope it helps!

View solution in original post

Highlighted
Contributor III
Contributor III

Thank you for your reply, but this is not exactly what I meant.

I'll try to better explain with this screen shot. The first group of KPIs (marked as 1) is in the organization level, and I used the “{<FieldToIgnore>}” in the measure expression so it's not affected by the District filter.

The second section is a multi KPI based on the district dimension. I want this section to display all districts even if the user chose only one. In this example I had to choose 6 of the districts in order to display them. I want to see all the 8 districts always.

The measures are correct. The issue is the header, the districts list.
Is there a way to disable the filter itself for this specific chart?

example.PNG

Highlighted
Partner
Partner

You can't disable a filter on object (Chart) level, so TimVb is right in his previous post. The expression with ignore field should do the trick. so Something like Sum({<District=>}Sales) should show you all 8 districts even when you select 1 district.

Highlighted
Creator II
Creator II

 

I just came up with a workaround to ignore all filters and still be able to apply specific filters to the Multi KPI object by using dynamic Set Analysis with the "{1}" identifier. Thus, the idea is that we ignore all filters excluding any selections made by predefined fields in the Set Analysis.

To do so, I used the following dynamic set analysis expression:

sum({1<[DoNotIgnoreField]={$(=If(GetSelectedCount([DoNotIgnoreField])=0,'*',GetFieldSelections([DoNotIgnoreField]))))}>}[Sales])

This expression includes "*" if  no selection is made for DoNotIgnoreField. If any selection is made, it (comma separated) lists the selected records for the field DoNotIgnoreField.

See my example where [District] is ignored and [Area] can still be applied to the top Multi KPI object in contrast to the regular Multi KPI object (bottom).

Limitations: (1) You need to specify all filters in the set analysis for user to able to apply. (2) Take into account the computational performance as the expressions can get very long. (3) It can be confusing for users when filters are disabled.

Hope it helps!

Multi KPI.gif

 

 

 

Highlighted
Contributor III
Contributor III

Thank you for the explanation.

I did it and it works 😀