Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Scheduler service not starting when there is not internet access

Hi guys,

Our customer. is controlling the internet access for our Qlik Sense server and they recently changed their proxy settings, which meant that there was no access to internet. After those changes, we were not able to start the Scheduler service and could not reload data for our apps. Restarts of the server did not help and manually starting the service was not possible.

They have temporarily lifted the internet restrictions and now the service starts up fine.

Can someone elaborate on which domains needs to be accessible before the scheduler service can startup. We need to provide these domains, so that our customer can whitelist those.

Best Regards

Rasmus

Labels (3)
1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Check out this qlik support article on How to extend Windows default timeout of 30 second

Plees ekskuse my Swenglish and or Norweglish spelling misstakes

View solution in original post

4 Replies
Highlighted
Partner
Partner

What happens if you start the service with an internet access and then restricts the access while the service is running? Does it still run? Is it only when  starting or restarting you have this issue.

I ran into a similar behaviour at a client of mine a while back. For some reason some of the services needed more time to start without internet than with. After contacting qlik support we ended up increasing the default timeout value for service startup on the server. In our case it solved our issues.

Plees ekskuse my Swenglish and or Norweglish spelling misstakes
Highlighted
Partner
Partner

Check out this qlik support article on How to extend Windows default timeout of 30 second

Plees ekskuse my Swenglish and or Norweglish spelling misstakes

View solution in original post

Partner
Partner

Thanks for you feedback. It does only seem to be an issue when we are restarting the server. Our customer has just restricted the internet access again, but whitelisted some Qlik.com domains - and that seems to do the trick. Restarting the server results in all of the services starting up as expected.

Im not completely convinced that whitelisting these domains should resolve the issue - unfortunately I cannot tell exactly what changes the customer has made. I can see from the log files, that Qlik is calling a few different services (on different ports) using its DNS hostname and my suspicion is that the server was not able to resolve the hostname (even though the hostname was pointing to the server itself = localhost). Perhaps this  was changed by the customer.

We will continue to monitor the system - and hopefully it is running normally again.

Highlighted
Partner
Partner

Thanks, this is definitely something that I will keep my eye on - as it could be the issue with some of our other customers.