Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

filipeoliveira
New Contributor III

Script works on QlikView but doesn't work on Qlik Sense

Hi all,

I'm writing a script in Qlik Sense (November version) but when I run the script it doesn't show the output I was expecting.

I've copied the same script to Qlik View and it works just fine!

Find below the script:

Qlik Script 1.PNG

Qlik Script 2.PNG

Can someone help?

Thanks in advance!

Mensagem editada por: Filipe Oliveira

Mensagem editada por: Filipe Oliveira

1 Solution

Accepted Solutions
MVP
MVP

Re: Script works on QlikView but doesn't work on Qlik Sense

Ok, then create a resident table with just the two fields as in your mapping table and your combined key aliased to CHAVE, also create this key field in your main table.

19 Replies
MVP
MVP

Re: Script works on QlikView but doesn't work on Qlik Sense

What do you mean with 'it doesn't show the output I was expecting'?

Can you describe where exactly it differed?

filipeoliveira
New Contributor III

Re: Script works on QlikView but doesn't work on Qlik Sense

Hi Stefan,

It was supposed to get a classification,other than the Apply Map default,(GCLASSIFICACAO) based on the product code (CPRODUTO).

Qlik Output1.PNG

Qlik Output2.PNG

zebhashmi
Valued Contributor

Re: Script works on QlikView but doesn't work on Qlik Sense

Qlik sense is sometime hard on data types in comparison to qlikview

Trye to use apply map with as.

Regards

filipeoliveira
New Contributor III

Re: Script works on QlikView but doesn't work on Qlik Sense

Hi Jahanzeb,

I'm sorry but I didn't get your point...I'm already using as to name (GLASSIFICACAO) the field "generated" by the ApplyMap function.

zebhashmi
Valued Contributor

Re: Script works on QlikView but doesn't work on Qlik Sense

I may be wrong but & in apply map got my focus

MVP
MVP

Re: Script works on QlikView but doesn't work on Qlik Sense

In your second LOAD, the INNER KEEP LOAD, shouldn't you rename your combined key to CHAVE as well, to get a key field between the first two tables?

clondono
Contributor III

Re: Script works on QlikView but doesn't work on Qlik Sense

I think what Jahanzeb is trying to tell you is to use an alias in the mapping load table:

Map_Classif_Prod:

Mapping Load

CPRODUCTO&CESTADO_BEM    AS      "Alias Name here"

.....

.....



Thanks,

Carlos

filipeoliveira
New Contributor III

Re: Script works on QlikView but doesn't work on Qlik Sense

I've tried that too but it's still not working...

filipeoliveira
New Contributor III

Re: Script works on QlikView but doesn't work on Qlik Sense

Hi Carlos,

I've tried that and the output is still the same.