Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

alessandro_mari
New Contributor III

Section Access doesn't work Qlik Sense September 2017

Good morning experts,

I'm Alessandro.

I have an issues with SA. Every time i try to access the file, sense turn to me an "Access Denied" error.  USERID is equal to Sense User name.

Thanks in andvance,

Alessandro

PS the same SA works in QlikView

section access;

Accessi:

load

'USER' AS ACCESS

,upper(USERID) as USERID

,NTNAME as USER

FROM [$(pathXLS)\Nuti.xls] (biff, embedded labels, table is Restrizioni$)

where not isNull(NTNAME);

concatenate (Accessi) load

'ADMIN' as ACCESS

,upper(trim(subfield('$(RestrictionsSuperusers)', ','))) as USERID

,'*' as USER

autogenerate 1;

1 Solution

Accepted Solutions
alessandro_mari
New Contributor III

Re: Section Access doesn't work Qlik Sense September 2017

Thanks to everibody, I solved the problem.

I used the wrong "DOMAIN"; I need to use the UserDiresctory instead

14 Replies
agigliotti
Honored Contributor II

Re: Section Access doesn't work Qlik Sense September 2017

in Qlik Sense the section access table doesn't have NTNAME field anymore but only USERID field.

USERID for domain users must be as "domain\username" of course.

take a look here https://help.qlik.com/en-US/sense/November2017/Subsystems/Hub/Content/Scripting/Security/manage-secu...

alessandro_mari
New Contributor III

Re: Section Access doesn't work Qlik Sense September 2017

I don't use NTNAME as SectioinAccess field. As you can see i rename it as USER because it's the field which I use to connect the SA table to the data model.

agigliotti
Honored Contributor II

Re: Section Access doesn't work Qlik Sense September 2017

first of all let's try to comment out the section access and check with OSUser() function if the user logged in the app match with your section access USERID entry.

alessandro_mari
New Contributor III

Re: Section Access doesn't work Qlik Sense September 2017

I've already done, and thre OSUser match with USERID.

It's in lowercase (OSUser) but if I remember it is automatically changed in uppercase

agigliotti
Honored Contributor II

Re: Section Access doesn't work Qlik Sense September 2017

all your section access fields value and fields name MUST be in uppercase.

dcj
Valued Contributor II

Re: Section Access doesn't work Qlik Sense September 2017

Dear Alessandro,

Have your tried to check if the domain name registered on licenses have a prefix instead of a single user name?

Anyway, the Section Access must be applyed on the APP, the document reloading and publishing it in a stream. All fields must be uppercase also.

Recommend that you close the Browser then try to access in the stream.

alessandro_mari
New Contributor III

Re: Section Access doesn't work Qlik Sense September 2017

Yes i've checked that. There is no prefix, only a single user name.

I have published it and relogged into sense by closing and opening the browser again. But when i try to access to the app it return to me Access Denied error

dcj
Valued Contributor II

Re: Section Access doesn't work Qlik Sense September 2017

Ok, try to reproduce the same code below, changin the user name only.

Managing security with section access ‒ Qlik Sense

We need to know either the problem is code or product.

alessandro_mari
New Contributor III

Re: Section Access doesn't work Qlik Sense September 2017

I tried with that code but it doesn't work yet.

Cattura.JPG

section access;

LOAD * inline

[ACCESS,USERID

USER,SANDRA

USER,OLGA];