Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

nikhilgarg
Contributor III

Section Access not working as expected in qliksense

Hello All,

In my qliksense application, i ahve taken binary load of a file and then implemented section access but it is not working as expected. Am i missing anything?

Thanks,

Nikhil Garg

1 Solution

Accepted Solutions
crusader_
Valued Contributor

Re: Section Access not working as expected in qliksense

Check available fields for SA in Qlik Sense They're different to QlikView...

Link to help provided earlier

There is no NTNAME anymore

//Andrei

7 Replies
crusader_
Valued Contributor

Re: Section Access not working as expected in qliksense

Hello,

Could you give more details on what's not working exactly?

User access? Data reduction?

It could whatever, so you definitely missing something.

//Andrei

nikhilgarg
Contributor III

Re: Section Access not working as expected in qliksense

When i am logging in on access point, it is asking me for credentials. When i am enetring my credentials(as ADMIN), it is giving error "Access Denied"

nikhilgarg
Contributor III

Re: Section Access not working as expected in qliksense

I have written following script:

Section Access;

LOAD

    upper("Access") as ACCESS,

    upper(NTNAME) as NTNAME,

    upper(Region) as REGIONCODE;

   

SQL SELECT "emp_code",

    "emp_fname",

    "emp_lname",

    "emp_Emailid",

    Status,

    "emp_password",

    "Access",

    NTNAME,

    Role,

    Region

FROM "QlikSense".dbo.LoginMaster;

Section Application;

LOAD

    REGIONCODE,

    SALES

FROM [lib://Desktop (abcd)/SectionAccess.xlsx]

(ooxml, embedded labels, table is Sheet1);

crusader_
Valued Contributor

Re: Section Access not working as expected in qliksense

Are you including DOMAIN\ both in SA and when entering credentials?

Have a look into https://help.qlik.com/en-US/sense/February2018/Subsystems/Hub/Content/Scripting/Security/manage-secu...

USERIDContains a string corresponding to a Qlik Sense user name. Qlik Sense will get the login information from the proxy and compare it to the value in this field.


Hope this helps

/Andrei

nikhilgarg
Contributor III

Re: Section Access not working as expected in qliksense

Yes, my domain name is included in NTNAME

crusader_
Valued Contributor

Re: Section Access not working as expected in qliksense

Check available fields for SA in Qlik Sense They're different to QlikView...

Link to help provided earlier

There is no NTNAME anymore

//Andrei

nikhilgarg
Contributor III

Re: Section Access not working as expected in qliksense

Thanks, this helps