Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

aitmessaoudali
New Contributor III

Section access-access denied

hello everybody,

i'm trying to create a section access on the script. I've tried so many scripts but i always get the error 'access denied'.

Here is the last script i used :

SECTION ACCESS;

LOAD * inline [

ACCESS, USERID,PROFIL_1

ADMIN, DOMAIN\AMESSAOUD,*

USER, DOMAIN \READER1,-1

USER, INTERNAL\SA_SCHEDULER,*

];

SECTION APPLICATION;

Star is *;

in the profil table, i renamed profil_1: upper(profil_1) as PROFIL_1

can someone please help me find where the error is?

11 Replies
Employee
Employee

Re: Section access-access denied

PROFIL_1 is not a valid field in Section access.  What are you trying to do ?

Possible fields are GROUP or OMIT.

rittermd
Honored Contributor

Re: Section access-access denied

If PROFIL_1 is the name of the field you are checking for the value then it must match the name in your table exactly.

Is your DOMAIN name really DOMAIN?

agigliotti
Honored Contributor II

Re: Section access-access denied

how are you using PROFIL_1 field in your data model ?

is there a field linked to it in your section application ?

Gabriel
Valued Contributor II

Re: Section access-access denied

Hi,

What are the values in PROFIL_1?

Do you actually have -1?

nsetty
Contributor II

Re: Section access-access denied

Isn't it NTNAME instead of USERID?  In the Section Access, if you are using domain accounts to login?

Section Access;

LOAD * INLINE [

    ACCESS, NTNAME,  OMIT

];

Section Application;

aitmessaoudali
New Contributor III

Re: Section access-access denied

PROFIL_1 is field filled with only 0 or 1

aitmessaoudali
New Contributor III

Re: Section access-access denied

they're matching

aitmessaoudali
New Contributor III

Re: Section access-access denied

no, i only have 0 or 1

aitmessaoudali
New Contributor III

Re: Section access-access denied

tried NTNAME, didn't work neither