Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
Not applicable

Sense Desktop 3.1 SR4 Problem with multiple accounts on same machine

Hi @mike_tarallo


I can't get Qlik Sense Desktop to work with multiple accounts on the same machine.


Here is my setup:

Windows 7 64-bit VM fresh image, member of domain, all sorts of group policies in place.


Downloaded Sense Desktop 3.1 SR4 to "All Users" Desktop for easy access.

Logged in as user with admin rights - install it successfully, I am able to open Hub.

Give admin rights to another userid. Log off and log in as user #2 with admin rights.

Installs successfully. User #2 is able to open Hub. Remove user #2 from Admin group and log off\log in back to make sure even without admin rights it still works - it does. Yay!

Now, i log in as local admin again and give user #3 admin rights. Log off and log in as user #3 (admin rights in effect)

Go through same sequence of installing the product - except this time user #3 cannot open Hub. Tried to refresh page with F5 just to get "Could not Reach http://localhost:4848/hub with error (-102)." message.


Tried uninstalling it, deleting %temp% files, deleting %appdata%\local\Programs folder, restart and then log in with admin rights as user #3 again and installing the Sense Desktop again but can't make it to work...


Log in as user #2 and application still works


I can't pinpoint the problem as it's intermittent. Can you help @mike_tarallo?

1 Solution

Accepted Solutions
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Found a problem The issue was in H: drive mapped for one user account - H: drive had "Documents" folder with a lot of logs. Once I disconnected H: drive, I was able to launch it and Hub opened up. I restarted, made sure H: drive connected again and launched Hub again and it worked this time as well. Problem solved. Thank you for all your hints and support.

17 Replies
cri
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Hi Alex - just making sure Mike is tagged

Hi mto‌ - as always, really appreciate your assistance!

CathyRDuvall
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Hi Alex,

Try pressing F5.

Michael_Tarallo
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Hi Alex,

So to recap - you are installing Qlik Sense Desktop - 3 times on the same VM using different user accounts?

I would need to reproduce this - in theory as long as each user is logged in with their own profile and they have permissions to install software locally, the installation should work.

Can you verify that you  have 3 separate installation APP directories in the users folders?

You should have 3 - if you installed it 3 times under each user account:

C:\Users\user1\Documents\Qlik\Sense

C:\Users\user2\Documents\Qlik\Sense

C:\Users\user3\Documents\Qlik\Sense

C:\Users\user1\AppData\Local\Programs\Qlik\Sense\QlikSense.exe

C:\Users\user2\AppData\Local\Programs\Qlik\Sense\QlikSense.exe

C:\Users\user3\AppData\Local\Programs\Qlik\Sense\QlikSense.exe

When Desktop Starts you should have:

C:\Users\user1\AppData\Local\Temp\qlik

C:\Users\user2\AppData\Local\Temp\qlik

C:\Users\user3\AppData\Local\Temp\qlik

I will attempt this and see what happens.

I am NOT using a domain account - I am using 3 local accounts.

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

Regards,

Mike Tarallo

Qlik

Regards,
Mike Tarallo
Qlik
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Hi Mike,

Below items are there:

C:\Users\user\Documents\Qlik\Sense

C:\Users\user\AppData\Local\Programs\Qlik\Sense\QlikSense.exe


When I launch Sense Desktop I have C:\Users\user\AppData\Local\Temp\QlikSenseBrowserCache instead of qlik folder and it does not go away when desktop is closed.


All of the above is valid for 3 different users, but only last one has problem opening the Hub

Michael_Tarallo
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Ok I sent out a request to the products team - this is odd - not sure if there is some sort of limitation, but you would think 3 separate installations under 3 separate user accounts would work. It is funny that 2 are working and 1 is not.

Can you check the log:

There should be a log file with desktop in the name here:

C:\Users\<user>\AppData\Local\Temp

something like: Qlik_Sense_Desktop_3.2_20170201152352.log

Mike

Regards,
Mike Tarallo
Qlik
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Hi Mike,

4 logs attached.

Thanks,

Alex

Michael_Tarallo
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Logs look good - please send some screenshots of what happens, see if you can launch

C:\Users\mtarallo\AppData\Local\Programs\Qlik\Sense\QlikSense.exe from a COmmand window that we can see if there are any messages or prompts

Also - do you have Qlik Sense Server / Enterprise installed on the same system - is this a server o/s or a workstation o/s? - I assume workstation as I think Desktop will not allow you to install on a server o/s. There are conflicts with Desktop and Server being installed on a workstation however.

Let's try to exhaust all possibilities.

Thanks,

Mike

Regards,
Mike Tarallo
Qlik
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

Hi Mike,

When I launch it from command line the command window gets closed and I get famous -102 error (attached) when it opens up. Sometimes I get another error - also attached. Pressing F5 few times gets me to 102 error as well.

I don't have any other Qlik software installed on this system. It's a 64-bit Windows 7 box. And remind you - that's the same exact VM that Sense Desktop works for first 2 users.

Thanks,

Alex

Michael_Tarallo
Not applicable

Re: Sense Desktop 3.1 SR4 Problem

I have seen that before upon start-up and I press F5 to refresh and works - this is definitely a weird issue - I am waiting on a support case for more information - there may be a known issue here - I'll update you shortly.

Regards,
Mike Tarallo
Qlik