Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Sense Proxy Settings for External Access

I have Sense set up on a windows Server 2012 R2. I am able to access the hub and QMC while connected to the same network. I am not able to access from outside the network. The IP of the machine is public and I can see it from outside the network using http. All ports are open and the firewall on the server is disabled. When I hit https://mywebaddress/hub I get a certificate error, I click to connect anyway and then the connection times out. I never get a prompt for credentials. Is there anything special that needs configured to allow this type of access?

Tags (2)
9 Replies
bvk
Contributor II

Re: Sense Proxy Settings for External Access

Check to see if you have both the external IP-address and/or the external DNS-entry listed in your proxy whitelist,

Not applicable

Re: Sense Proxy Settings for External Access

Also, you might try adding the IP address of the Qlik Sense Server to the proxy's "whitelist" which is available in the QMC under the Proxies option and scroll down to the bottom of the page and add the IP. You need to enter the IP address for the server not the client.

philipp_kunz
Contributor

Re: Sense Proxy Settings for External Access

Hi David,

Have you tried the following:

(Anonymous Access, HTTP enabled)

1.Create new access rule and apply tokens to it:

0.JPG

2.Edit the rule like this:

1.png

2.png

3.png

your external server IP-address here:

4.JPG

try your link with http://<Serveraddess/hub>

grangerats
New Contributor III

Re: Sense Proxy Settings for External Access

I know this is old, but it's almost certainly because Qlik runs its authentication services on a different port. Since that wasn't your first guess, it's reasonable to assume that you're running with defaults. And that means your default Virtual Proxy is still configured to use Windows Authentication via Http-Auth (the browser pops-up a credential dialog for you to login).

If that's the case, then the issue is that you haven't setup a port-forward for port 4244 like you did for 443---on your external firewall/router. The problem is the same if you changed the Virtual Proxy's Windows authentication pattern from "Windows" to "Forms".

In other words, a successful login process is like so:

  1. Go to  https://mywebaddress/hub
  2. Redirects to a page at https://mywebaddress:4244/windows_authentication/?targetId={GUID} which causes your browser to popup its built-in authentication dialog box.
    • This is where you're getting the timeout.
  3. After putting in good credentials, the Windows Authentication page redirects you back to here to login to the Virtual Proxy:  https://mywebaddress/hub/?qlikTicket={ticket}
  4. You are finally redirected back to the original URL: https://mywebaddress/hub


And, yes, you'll still need to add the "mywebaddress" DNS name to the Virtual Proxy's whitelist.

Not applicable

Re: Sense Proxy Settings for External Access

Hi,

We are also trying to connect mobile devices to our secure network and experiencing problems. We are using MobileIron which enables our users to access our network securely.  When trying to access the Qliksense hub : https://ourserver.company.uk it redirects to

https://ourserver.company.uk:4244/form/?targetid=.............. and then times out.   We are really struggling to get our apps rolled out to our user out in the field.

Can anyone help???

Many thanks

grangerats
New Contributor III

Re: Sense Proxy Settings for External Access

What have you tried? Does it work in a normal browser? Have you confirmed that your firewall (MobileIron?) has port 4244 open and forwarded properly to port 4244 on the Qlik server?

samuel_lin
Contributor

Re: Sense Proxy Settings for External Access

Hi,

I am also running Windows Server 2012 R2, and am experiencing the same issue. If trying to access as a user on Windows Server 2012 R2, there's no problem. However, if trying to access in the same network but not in the same windows server instance, then a user will be able to get in, but will only see the qliks' bubbling...

I see the it's redirected to http://XXX.XX.XX.X:4248/windows_authentication/?targetId=1b42125b-8ee2-40ca-9a1e-863c47cd27ed, port 4248;

1. the firewall on Windows Server 2012 R2 has already been disabled, do I need to enable it and add port 4248? any other port to add? any instructions on how to add additional port?

2. Is there a way to replace 4248 with a standard port?

Thanks,

Samuel

lathakatti
New Contributor II

Re: Sense Proxy Settings for External Access

If I do not whitelist my client IP address, it throws web socket connection error, how to get rid of this?

mall1m
New Contributor III

Re: Sense Proxy Settings for External Access

Hello, does anybody manage to solve this problem ?

We are stuck at connecting to QS server using mobileIron

(dns and domain have been whitelisted, all ports are open, we manage to login and reach the QS hub but we encounter a pop up saying its impossible to connect to QS engine for "unknown reason")