Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

mohan_1105
Contributor III

Session Access Not working for user

Hello Qlikers,

I have written the section access in my application, while the user tries to log in they are getting message "Access Denied".

I restricted my login(administrator) in section access and validate it in the application. Section access is successfully applied in my login. For other users, they are getting "Access Denied" message.


Also, I'm using the Binary function in my script. The section access is defined after the binary load.

Kindly provide solution...!!

Regards,

Mohan

1 Solution

Accepted Solutions
agigliotti
Honored Contributor II

Re: Session Access Not working for user

reviewing your section access inline table let's try using the below one:

ACCESS,USERID,SA_SECTION

ADMIN,MDSTIQLIK\ADMINISTRATOR,ALLVALUES

USER,MDSTIQLIK\PRASADV,ASM_C2OC_ZSM_EAST

USER,MDSTIQLIK\PRASADV,ASM_E1NE_ZSM_EAST

USER,MDSTIQLIK\PRASADV,ASM_E1WB_ZSM_EAST

USER,MDSTIQLIK\PRASADV,ASM_E2BR_ZSM_EAST

USER,INTERNAL\SA_SCHEDULER,ALLVALUES

USER,MDSTIQLIK\KKATHIRAVAN,ASM_C2OC_ZSM_EAST

USER,MDSTIQLIK\KKATHIRAVAN,ASM_E1NE_ZSM_EAST

];

and check how the app works using ADMINISTRATOR user with ADMIN as ACCESS type.

23 Replies
jananireddy
Contributor

Re: Session Access Not working for user

Hi Mohan, Can you provide your script so that we can check when the error is

mohan_1105
Contributor III

Re: Session Access Not working for user

yeah..!!

mohan_1105
Contributor III

Re: Session Access Not working for user

Hi Janani,

Binary [lib://SenseApps (mdstiqlik_administrator)/586bd11f-6045-4d66-af3b-61683XXXXXXX];

section access;

LOAD * inline [

ACCESS,USERID,SECTION

USER,MDSTIQLIK\ADMINISTRATOR,_

USER,MDSTIQLIK\ADMINISTRATOR,ASM_C1MV_ZSM_WEST

USER,MDSTIQLIK\ADMINISTRATOR,ASM_C2OC_ZSM_EAST

USER,MDSTIQLIK\ADMINISTRATOR,ASM_E1NE_ZSM_EAST

USER,MDSTIQLIK\ADMINISTRATOR,ASM_E1WB_ZSM_EAST

USER,MDSTIQLIK\ADMINISTRATOR,ASM_E2BR_ZSM_EAST

USER,MDSTIQLIK\ADMINISTRATOR,ASM_N1NR_ZSM_N1N2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_N2NR_ZSM_N1N2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_N3NR_ZSM_N1N2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_N4RJ_ZSM_N1N2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_S1TN_ZSM_S1S2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_S2KA_ZSM_S1S2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_S2KL_ZSM_S1S2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_S3AP_ZSM_S1S2

USER,MDSTIQLIK\ADMINISTRATOR,ASM_WEGJ_ZSM_WEST

USER,MDSTIQLIK\ADMINISTRATOR,ASM_WEMH_ZSM_WEST

USER,MDSTIQLIK\PRASADV,ASM_C2OC_ZSM_EAST

USER,MDSTIQLIK\PRASADV,ASM_E1NE_ZSM_EAST

USER,MDSTIQLIK\PRASADV,ASM_E1WB_ZSM_EAST

USER,MDSTIQLIK\PRASADV,ASM_E2BR_ZSM_EAST

USER,INTERNAL\SA_SCHEDULER,*

USER,MDSTIQLIK\KKATHIRAVAN,ASM_C2OC_ZSM_EAST

USER,MDSTIQLIK\KKATHIRAVAN,ASM_E1NE_ZSM_EAST

];

section application;

star is *;

jananireddy
Contributor

Re: Session Access Not working for user

Hi Mohan,

Can you try adding using * for administrator(as highlighted in the below code) and login in with administrator access and check the app. In that way you will be sure the section access works, then we could dig into the data reduction part

section access;

LOAD

Upper([ACCESS]) as ACCESS,

Upper([USERID]) as USERID,

REDUCTION;


LOAD * inline [

ACCESS, USERID,REDUCTION

USER, Domain\ADMINISTRATOR,*,

USER, Domain\USER1,IDXXX1,

USER, Domain\USER1,IDXXX2,

.

.

.

.

.

USER, Domain\USERN,ID_XXXN,

USER, INTERNAL\SA_SCHEDULER,*,

];

section application;



agigliotti
Honored Contributor II

Re: Session Access Not working for user

where is your reduction field on section application?

I can't see it in your script.

and are you using section access also inside app 586bd11f-6045-4d66-af3b-61683XXXXXXX ?

mohan_1105
Contributor III

Re: Session Access Not working for user

Hi Janani,

I wanted administrator to see all the section in the application. So, I added all the attribute in the field to administrator and restricted the user with the selected attribute of the field.

I suppose the meaning of * in section access is the user with " * " is allowed to the "ALL" mentioned attribute.

mohan_1105
Contributor III

Re: Session Access Not working for user

Hi Andrea,

No...!!

Because Section access will work only after binary load. Right?

Regards,

Mohan

jananireddy
Contributor

Re: Session Access Not working for user

Yes thats right a wildcard is meant to allow access to all. You can pass * and try as this will make your query smaller and will avoid any issues wrt to data mismatches

jananireddy
Contributor

Re: Session Access Not working for user

Hi Andrea, I guess his filed is 'SECTION' as seen in his query

Community Browser