Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

ziadm
Valued Contributor

UNC Path no longer working on Qliksense Scheduler

Hi

This is Qliksense server related question@ !

I have 3 apps scheduled to do data extraction on Qliksense serve scheduler and of sudden these apps failed to load with the error message that UNC path is not supported use Lib Path instead in this SCRIPT MODE

2016-03-17 22:00:39 0130   STORE  Semaphore into "\\MyserverPath\Data Lake\iPower Staff iTime Data Restricted T1\Source\iTime Daily\JOB WRITING.txt" (txt)

2016-03-17 22:00:39        Error: STORE statement only works with lib:// paths in this script mode

2016-03-17 22:00:39        General Script Error

2016-03-17 22:00:39        Execution Failed

2016-03-17 22:00:39        Execution finished.

Appreciate your feed back how script mode can be changed to support the UNC path insrtead.

Regards

Ziad

Tags (1)
1 Solution

Accepted Solutions
p_verkooijen
Valued Contributor

Re: UNC Path no longer working on Qliksense Scheduler

Hi,

In a QlikSense server you also have to disable standard mode.

Editing engine ‒ Qlik Sense

Standard mode

When selected, standard mode is used. If cleared, legacy mode is used. Standard mode is the default mode that prevents actions that are potentially harmful. Standard mode is to be used unless there are special reasons not to. Legacy mode can be used for running QlikView load scripts unchanged, when loading data into Qlik Sense.

For security reasons, Qlik Sense in standard mode does not support absolute or relative paths in the data load script or functions and variables that expose the file system.

4 Replies
reddys310
Honored Contributor II

Re: UNC Path no longer working on Qliksense Scheduler

Hi Zaid,

Try creating a folder connection to the path you are trying to save the file to. If not you will have to change the settings.ini file:

Do the following:


Open C:\Users\{user}\My Documents\Qlik\Sense\Settings.ini in a text editor.

Change StandardReload=1 to StandardReload=0.


Thanks,

Sangram.

ziadm
Valued Contributor

Re: UNC Path no longer working on Qliksense Scheduler

Thanks Sangram

I have already have this setting done changing into legacy mode on my local machine.

This error I am getting on the server only.

If app is run on local machine it's working fine with UNC path but if it's scheduled on the server it stops with error given above.

I should say that server is having access to the path and definitely tested. 

srchilukoori
Valued Contributor

Re: UNC Path no longer working on Qliksense Scheduler

Hi Ziad,

Try creating the connections to the folders and use the Lib path in the applications.

p_verkooijen
Valued Contributor

Re: UNC Path no longer working on Qliksense Scheduler

Hi,

In a QlikSense server you also have to disable standard mode.

Editing engine ‒ Qlik Sense

Standard mode

When selected, standard mode is used. If cleared, legacy mode is used. Standard mode is the default mode that prevents actions that are potentially harmful. Standard mode is to be used unless there are special reasons not to. Legacy mode can be used for running QlikView load scripts unchanged, when loading data into Qlik Sense.

For security reasons, Qlik Sense in standard mode does not support absolute or relative paths in the data load script or functions and variables that expose the file system.