Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Save the Date: QlikWorld Online, June 24-25, 2020. Free global virtual event for data integration and data analytic gurus. Register Today
New Contributor III

USER Directory Connector Error.

Hi,

I have an issue regarding the User Directory Connectors. I have created an ODBC connection for SQL and tried to create User Directory Connector SQL(Via ODBC). Below is the screen Shot of the Connector I have created. But I am still getting an error. I have tried many things but I could not resolve it. I could not see any issue with the connection. But still still it is not working..Kindly help me with it.

1.JPG

Thanks in Advance...

1 Solution

Accepted Solutions
Highlighted
New Contributor III

Re: USER Directory Connector Error.

Hi Bilal,

I have found the solution for my problem. This worked fine after making the following changes.

1. Removing the database name and schema from table 1 and table 2

2. Including Uid={};Pwd={} at the end of the string providing username and password

View solution in original post

4 Replies
Highlighted
Partner
Partner

Re: USER Directory Connector Error.

Hi Avinash,

Please refer below  Thread it may help you:

User directory Connectors (UDC) in Qlik Sense

Thanks,

Arvind Patil

Highlighted
Partner
Partner

Re: USER Directory Connector Error.

Hi Avinash,

We had a similar problem connecting to Teradata. Can you add the port in connection string as well ? We had missed the port number from connection string and were facing the same issue, but after adding the port the UDC worked just fine.

Highlighted
New Contributor III

Re: USER Directory Connector Error.

Hi Arvind,

Thanks for your reply. That thread was really helpful but even if I configured it the same way, I was getting the error. I was thinking if I was missing any inverted comas while giving the server name or database name. Or do I need to specify the username and password?? If so, how?? Any help on that is highly appreciated.

Thanks.

Highlighted
New Contributor III

Re: USER Directory Connector Error.

Hi Bilal,

I have found the solution for my problem. This worked fine after making the following changes.

1. Removing the database name and schema from table 1 and table 2

2. Including Uid={};Pwd={} at the end of the string providing username and password

View solution in original post