Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

chandni90
New Contributor III

Upgrade Qliksense

I am using Qliksense Enterprise. How do I upgrade from 2.0.6  to 2.2?

1 Solution

Accepted Solutions
Employee
Employee

Re: Upgrade Qliksense

In general it is as simple as running the installer. It's ideal to have all services except the Repository Database down so that things aren't being done during the install process (e.g. reloads or users access apps).

It is always good practice to get into the habit of having a VM snapshot or backup of the site (https://help.qlik.com/en-US/sense/2.2/Subsystems/PlanningQlikSenseDeployments/Content/Server/Server-...) prior to running an upgrade. On the support side, we've had customers encounter issues with upgrades from time to time and those who have proper backups make things easier on us.

8 Replies
ecolomer
Honored Contributor II

Re: Upgrade Qliksense

You can download it in web www.qlik.com

Employee
Employee

Re: Upgrade Qliksense

In general it is as simple as running the installer. It's ideal to have all services except the Repository Database down so that things aren't being done during the install process (e.g. reloads or users access apps).

It is always good practice to get into the habit of having a VM snapshot or backup of the site (https://help.qlik.com/en-US/sense/2.2/Subsystems/PlanningQlikSenseDeployments/Content/Server/Server-...) prior to running an upgrade. On the support side, we've had customers encounter issues with upgrades from time to time and those who have proper backups make things easier on us.

chandni90
New Contributor III

Re: Upgrade Qliksense

Thanks.

luizcdepaula
Contributor II

Re: Upgrade Qliksense

Hello Levi,

We installed Qlik Sense update 2.2 and it worked successfully. Clean installation and all apps were migrated successfully as well.

The apps are working, however, the connection to SAP is not working. Getting error message below.

RfcPing failed. Key = RFC_INVALID_HANDLE (An invalid handle was passed to the API call)

We checked the SAP connector, and it is working. Changed the connection string, but still did not connect. Have you seen a similar case? I saw some similar posts with the same error, not nobody has answered correctly yet.

Any suggestions?

Thanks,

LD

Employee
Employee

Re: Upgrade Qliksense

I recommend that you open up a support ticket with us (using the portal ideally but also support@qlik.com if you do not have portal access). This isn't something that I am familiar with and will likely require more in-depth troubleshooting.

luizcdepaula
Contributor II

Re: Upgrade Qliksense

Will do that and update when the problem is resolved.

Thanks

LD

chandni90
New Contributor III

Re: Upgrade Qliksense

Running the existing setup file gives me the option to modify. To upgrade, we need to download the setup file again and then run it? If so, do we need to uninstall the existing one first?

sunindia

kevincase
Contributor II

Re: Upgrade Qliksense

Chandni,

You need to download the installer for 2.2.  Every release has a new installer.