Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

sridhar1
New Contributor III

Upgrade to Shared Persistence in Qlik Sense

Hi All,

Want to move to Shared Persistence from Synch Persistence and Current version we are on is 3.1SR1

I want to upgrade to 3.2.4 with Shared Persistence do I need to upgrade to 3.1 SR2 first and then move to 3.2.4 or Can I upgrade directly from 3.1 SR1 to 3.2.4 with Synch and follow the steps to move to Synch to Shared from the attached document(See Section 5.7)

Thanks

Tags (1)
1 Solution

Accepted Solutions
ogster1974
Honored Contributor II

Re: Upgrade to Shared Persistence in Qlik Sense

I upgraded from 3.1 to 3.2.4 with no problem.  there is a new release out end of June so might want to wait for that.

If you use extensions in your apps I'd check on a tester sever they still work before upgrading your production.  I have had some issues around then not working without some fixes to them. 

8 Replies
ogster1974
Honored Contributor II

Re: Upgrade to Shared Persistence in Qlik Sense

I upgraded from 3.1 to 3.2.4 with no problem.  there is a new release out end of June so might want to wait for that.

If you use extensions in your apps I'd check on a tester sever they still work before upgrading your production.  I have had some issues around then not working without some fixes to them. 

mg_gsi_da
New Contributor III

Re: Upgrade to Shared Persistence in Qlik Sense

Hi,

we are just using one server. How can I determine if the system is configured as shared persistence or syc. persistance?

Is there a config file to look at to find out?

ogster1974
Honored Contributor II

Re: Upgrade to Shared Persistence in Qlik Sense

If you look at this it depends where you are upgrading from. I was 3.1 SR1 so I knew it was Synchronized.

http://help.qlik.com/en-US/sense/3.2/Subsystems/Installation/Content/InstallationLicensing/Upgrading...

sridhar1
New Contributor III

Re: Upgrade to Shared Persistence in Qlik Sense

Thanks Andy it really helped and we upgraded to 3.2SR4 without any issues.

silvacarlos
Contributor II

Re: Upgrade to Shared Persistence in Qlik Sense

Hi Andy, sorry that I'm in this solved topic, but I need help with this:

We currently have 3.1 SR1, with Sync Persistence. We need upgrade to June 2017. We've planned to upgrade to 3.1 SR2, and then to June 2017.

Can I upgrade to 3.1 SR2 with Sync persistence and then to June 2017? Or I need to upgrade to a shared persistence before this steps?

sridhar1
New Contributor III

Re: Upgrade to Shared Persistence in Qlik Sense

Hi Carlos,

Based on my experience we need to first Upgrade to 3.1 SR2 which is with Sync Persistence and then you need to upgrade to June 2017.

Even documentation says first upgrade to Sync Persistence Mode and then upgrade to latest version.

Hope this helps!!!

Thanks

silvacarlos
Contributor II

Re: Upgrade to Shared Persistence in Qlik Sense

Thank you so much Sridhar, next week we will upgrade this so I'll do this!

Regards

CS

rohitk1609
Valued Contributor II

Re: Upgrade to Shared Persistence in Qlik Sense

Hi Carlos,

You don't have to first upgrade your 3.1 to 3.4 to Shared persistence and then migrate to Qlik Sense June 2017,  The point is, which ever 3.X version you have, it will ask for shared persistence. So no matter you upgraded 3.X to shared or not, it will ask you when you install Qlik Sense June 2017.