Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

jeshwinm
New Contributor II

Values labels disappear in pivot table

Hi all,

I'm using a pivot table which shows users count across months and colored it with measure(Background color expression) as shown.

I don't know what happened, the color for value labels become transparent. I have now hard-coded black value in text color labels to fix it.

Capture.JPG

Could somebody help me out of this issue, why this is happening and what is the permanent fix.

I'm using Qlik Sense June 2017 edition.

5 Replies
MVP
MVP

Re: Values labels disappear in pivot table

Do you have a sample QVF application to share so we could have a look at it?

jeshwinm
New Contributor II

Re: Values labels disappear in pivot table

Hi Petter,

This issue is occurring randomly. Sometimes reloading the app resolves the problem and sometimes just closing the session and opening the hub again also resolves it.

Just wanted to know why is issue is occurring and is there any fix available for it?

kaanerisen
Contributor III

Re: Values labels disappear in pivot table

Hi,

June 2017 has a bug which is your specific problem randomly occured as far as i know.

Upgrade your qlik sense enviroment to the latest version and see if it works or you can write "black()" to measure's text color to force the qlik showing it as black.

hope it helps.

jeshwinm
New Contributor II

Re: Values labels disappear in pivot table

Hi Kaan,

Thanks for your reply.

I had this problem before upgrading to June 2017 version too. Are you sure this problem is rectified in November 2017? Upgrading Qlik will take a while in our organisation.

And, as you said, I'm forced to use Black() to fix it temporarily.

kaanerisen
Contributor III

Re: Values labels disappear in pivot table

Hi Jeshwin,

I am not sure this problem is fixed  but I haven't experience it in november 2017 yet. In the november 2017 release notes, there is a fixed issue that might be related with this specific problem.

Pivot table data is missing when moved to another sheet

Jira issue ID: QLIK-77109

Description: Data does not appear in a pivot table after the table is moved to another sheet. Problem appears in Desktop, not in server.

Community Browser