Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

morenoju
Contributor II

Variable does not seem to update in published app

Hi,

I have a variable called "vMaxTimePeriodIdx" in my load script. If from the Data Load Editor, I click "Load Data", this variable gets a new value according the script, and everything works as expected.


However, if I publish the app and I set up a periodic reload, this variable does not seem to update. I have a trace in the load script, so I can see in the log that the variable takes the corresponding new value, but if I put a KPI or any other object in a dashboard it remains with the value previous to the load.

How can the same script behave different in the published app? Any idea on what may be happening? H

Thanks,

Juan

---

TempDWHMaxUpdate:

LOAD MaxUpdateTimestamp15Min;

SQL SELECT max(start_date) as MaxUpdateTimestamp15Min FROM measure_update WHERE period = '15min'; //and start_date >= CURRENT_DATE;

if NoOfRows('TempDWHMaxUpdate') > 0 then

   

    vMaxTimePeriodDate = Date(Timestamp(peek('MaxUpdateTimestamp15Min', 0, TempDWHMaxUpdate)), 'YYYY/MM/DD');   

    vMinDWHMaxUpdate = Minute(Timestamp(peek('MaxUpdateTimestamp15Min', 0, TempDWHMaxUpdate)));

    if (vMinDWHMaxUpdate >= 0 and vMinDWHMaxUpdate < 15) then

       vPeriod = 0;

    elseif (vMinDWHMaxUpdate >= 15 and vMinDWHMaxUpdate < 30) then

       vPeriod = 1;

    elseif (vMinDWHMaxUpdate >= 30 and vMinDWHMaxUpdate < 45) then

       vPeriod = 2;

    elseif (vMinDWHMaxUpdate >= 45 and vMinDWHMaxUpdate < 60) then

       vPeriod = 3;      

    end if;

   

vMaxTimePeriodIdx = Hour(Timestamp(peek('MaxUpdateTimestamp15Min', 0, TempDWHMaxUpdate))) * 4 + vPeriod;

end if;

Drop Table TempDWHMaxUpdate;

TRACE >>> Latest 15 min link update time period index:  $(vMaxTimePeriodIdx);

8 Replies
morenoju
Contributor II

Re: Variable does not seem to update in published app

By the way, if I duplicate the Published App, the duplicate does show the vMaxTimePeriodIdx variable updated in the dashboards. But the published keeps showing the old value.

countwise
New Contributor II

Re: Variable does not seem to update in published app

Hi Juan,

I am having a similar problem.

Take a look at:

https://community.qlik.com/inbox?objectType=2&objectID=1459858

Regards

Jim Diggins

DavidŠtorek
Contributor III

Re: Variable does not seem to update in published app

Hi all, it seems to be some kind of a bug. mto‌ does your team knows something about it. It seems that variable do not propagate with published app. It cause the same proble even for those variable created in front-end. Thanks in advance.

morenoju
Contributor II

Re: Variable does not seem to update in published app

Jim, your link is not working for me. Anyway, I ended up assuming this was a bug and I rebuilt my app with a totally different approach to bypass the issue.

Regards.

Employee
Employee

Re: Variable does not seem to update in published app

Hi Guys - I personally would have to test - but when things like this occur you can open a case (even as a guest) with our customer support - to make sure it gets logged - information like this is valuable to us and you can reference this link in the case so you don't have to rehash everything. Be prepared to provide repro steps however. let us know how you do. I will update this with my latest release April 2018 of Qlik Sense.

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

Regards,

Michael Tarallo

Qlik

rvijayanth
New Contributor III

Re: Variable does not seem to update in published app

Did anyone find a solution for this?

This is a major issue for us.

rvijayanth
New Contributor III

Re: Variable does not seem to update in published app

Were you able to test this?

In our public facing dashboard, we have designed extensions to show pop up "disclaimer" window based on variable values. If the variables behave unexpectedly then we will have major functional issues. Please update us if this is a bug.

rvijayanth
New Contributor III

Re: Variable does not seem to update in published app

How did you solve this issue?