Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Where clause not working on date

Hi all- I'm trying to limit the load of my data based on date and Qlik is just completely ignoring it- I'm so confused. I've tried all sort of combos of date() and num() etc and nothing works- it keeps ignoring my where clause and loading the full data set. Help? Any ideas? the reducing field is a normal date format (MM/DD/YYYY) and I've tried what I usually use 

'WHERE datefield >= makedate(2016,10,1)' as well as WHERE datefield >= '10/1/2016' to no avail.

If it's an issue with format interpretation I haven't been able to figure out what exactly the problem is. I have a test field in the data itself that basically puts that where clause as an if statement flag field, and the result is as expected- so why won't it work in the load?

Labels (1)
3 Replies
Contributor II
Contributor II


Visually your field looks like a date field, but it's probably interpretated by Qlik like a string. Convert your field and then apply the formatting date : Date(Date#(Field),'MM/DD/YYYY'). After that, your filter will work.


Contributor III
Contributor III

Unfortunately I've tried that and it still doesn't work  😞


Can you post your entire Load statement?