Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
Not applicable

data missing from charts after adding additional table.

I can see the associations and the tables in the data viewer, however when I added an additional table, the data from the charts disappeared without warning.

Is there an option I need to click to resync?

Thanks

5 Replies
Not applicable

Re: data missing from charts after adding additional table.

It's worth noting, I selected 'Load data' as well.

Re: data missing from charts after adding additional table.

Not sure I understand the issue you are running into, can you elaborate?

Not applicable

Re: data missing from charts after adding additional table.

Hi Sunny.

Data is not being shown in any of my charts anymore, they're all empty. This began as soon as I added an additional table. When I look at the expression fields for each chart, they're highlighted in red. It's like it wants me to resync.

Re: data missing from charts after adding additional table.

May be you are dropping your existing table and you need to add NoConcatenate while creating the new table. Did you add NoConcatenate when you created a new table?

Employee
Employee

Re: data missing from charts after adding additional table.

The red lines in expression editor indicates a syntax error. This can be incorrect function definition or missing field name. If your data model is empty it is then a strong indicator that your application has no data. This is not a bug, but caused by the logic in your script.

The only way we can help identify the root cause is that you provide a sample of the document reload log. This will enable analyzing where your script removes the data.