Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
DominiC181
Contributor II
Contributor II

disable filters

Hi everyone.

I have this expression in pivot table:

=(If (v_currency= 'EUR',Sum({1<Month={"<=$(=vvmaxmonth)"}>}[M EUR]),

Sum({1<Month={"<=$(=vvmaxmonth)"}>}[M USD]))

/1000000)

 

Variable Vvmaxmonth give me max. month of max. year.

Expression give me a cumulative results for every year in pivot table based on vvmaxmonth

For max. 2022/Feb

2022 : Jan + feb 2022

2021 : Jan + Feb 2021

2020 : Jan + Feb 2020

And it works fine for me until I start filtering. When I choose in year filter only 2021 year, table gives me sum for all twelve months in 2021. I don’t want it.

I want to avoid filters. I need to keep only one results in table. How to disable all filters?

Any ideas?

Thanks for any help.

Labels (1)
1 Solution

Accepted Solutions
LucasBarbosa
Partner
Partner

I believe the problem is in the creation of the Vvmaxmonth variable.

Try adding the filter lock (1 or Year) directly to it.

Something like that: 

Date(Max( {1} [DateValue]))

View solution in original post

2 Replies
LucasBarbosa
Partner
Partner

I believe the problem is in the creation of the Vvmaxmonth variable.

Try adding the filter lock (1 or Year) directly to it.

Something like that: 

Date(Max( {1} [DateValue]))

DominiC181
Contributor II
Contributor II
Author

Hi Lucas,

thank you for your advice. Now it works properly.

Have a nice day 🙂