Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

oz_moyal
New Contributor II

extension in mashup permission/authentication issue

Hi all,

In my code i get qlikticket string, then load an image from the qlik server with the qlikticket in querystring, it loads

then i load all the js/css files from qlik server and they load fine, so it seem the authentication works

I am also able to display a chart in the mashup

the issue is with extension (actully a widget, but i think it loads the same), it seem that when the browser try to load it, it get 302 redirection to the login page, which returns "401 unauthorized"

Can u suggest what shall i check to make sure the extension can be read by the user ?

in the qmc, the extension has read permission for all users.

4 Replies
oz_moyal
New Contributor II

Re: extension in mashup permission/authentication issue

To add more info

when i load the extension in single configuration (iframe) it loads fine

but not when i load it as object in mashup..

erik_wetterberg
Honored Contributor

Re: extension in mashup permission/authentication issue

Hi,

Open the browser console and look for errors. What URL:s are referenced? Do you use a virtual proxy and if so is the proxy missing from some calls? Does this happen for all widgets or just some/one??

Hope this is some help

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
oz_moyal
New Contributor II

Re: extension in mashup permission/authentication issue

HI Erik!
Thanks for your comments.
yes, I use virtual proxy - called vpx

when the widget is called (called widget-examples):

https://***myhost**/vpx/extensions/widget-examples/5d725b77-f0d7-5f8b-51fc-3c91c2dcf331.json?1521327...

(by the way i see in log two calls like this

So it used the virtual proxy in the call

but this call returns 302 redirect to
https://***myhost***:4244/windows_authentication/?targetId=124f1c2f-91ed-44ce-a98e-b0bb534bd79b


Any help appreciated...  getting desperate here


adding two screenshots, one of the log , and one of how the widget is rendered, it says something about "invalid css" but i'm not sure it is actual error due to the 302 and 401 and also becuase the widget shows correctly on iframe or in dev-hub (single configuration)


Capture3.PNG



Capture4.PNG

erik_wetterberg
Honored Contributor

Re: extension in mashup permission/authentication issue

Hi,

Seems like there is a problem with loading json files. These are widget-specific, there are no json files in extensions (well you could add one yourself, but I don't think it's common). Not sure why you would need them in a mashup though, they are mostly for the property panel. How do you load them? app.getObject() ??

You should probably report this to support and se if they have a solution for you.

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
Community Browser