Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Highlighted
JGande19
New Contributor

filtering removing all entries

Hi,

I have an excel file with a table of measurements across 4 different regions.  A measurement in a region generates a 1, and instead of having a NULL value with no measurement, I've instead created a -1.

When filtering >=0 for the regions no entries are uploaded. I've also tried with =1, >=1, but with the same result

"Results: 0 (generated:0, existing:0)"

What can I do to resolve this?

Region ARegion BRegion CRegion D
-1 -1 -1 -1 
1-1 -1 -1 
1-1 -1 -1 
1-1 -1 -1 
1-1 -1 -1 
Labels (1)
9 Replies

Re: filtering removing all entries

Would you be able to elaborate a little? I don't think I am able to understand the intent here

JGande19
New Contributor

Re: filtering removing all entries

Hi,

The excel sheet contain measurements of network assets in each of the regions A, B, C, D. The purpose is to visualize the different measurements per asset and per region. Each asset belong to a certain type of technology: 2G, 3G, 4G.

In the column for Region, there is inserted 1 when there is a reading, and a -1 when there is none. I've changed the original NULL value to a -1 to make it easier to filter. If I maintain the NULL value then for each region I also get the measurements for all regions.

When I create the app, I connect to my excel sheet, and then go to filtering. I've set the filter for each Region to  >=  and the value 1. This way only the measurements for that region ought to be shown. However, all measurements and values get filtered out, and I get the feedback that there are no values in the tables.

I hope this makes sense.

Thanks in advance.

 

 

 

 

 

Re: filtering removing all entries

Would you be able to share your app so that we can see what is going on?

JGande19
New Contributor

Re: filtering removing all entries

Hi,

I cannot publish the app. I have tried to attache the qvf file, but get the error message stating "The contents of the attachment doesn't match its file type."

Not sure what else to try...

 

 

Re: filtering removing all entries

You need to zip the file before you can upload it here.

JGande19
New Contributor

Re: filtering removing all entries

Great. Here it comes

Re: filtering removing all entries

So, using the same script and your attached sample file... I get this by reloading...

image.png

JGande19
New Contributor

Re: filtering removing all entries

Hi,

A couple of points, which might be important.

I only filter on Region A, B, C, D - which I thought would not affect any other column. But that might be a mistake?

I've double checked on the excel file to make sure there are 1 in the columns for the different regions. Below find an extract from the most recent test I've done this morning. Still the same result - Result: 0 (generated: 0, existing: 0). Can there be a problem in the upload from my C drive to Qlik?

I've attached both the excel file and the Qvf.

 

BaseIdAssetGroupIdLocationLevelRegionLocRegion ARegion BRegion CRegion DRegionsServed
10821  00-1 -1 -1 -1 0
108221A00108221A001A1-1 -1 -1 A,B,C,D
108231A00108231A001A1-1 -1 -1 A,B,C,D
108241A00108241A001A1-1 -1 -1 A,B,C,D
108251A00108251A001A1-1 -1 -1 A,B,C,D
108261A00108261A001A1-1 -1 -1 A,B,C,D
108271A00108271A001A1-1 -1 -1 A,B,C,D
108281A00108281A001A1-1 -1 -1 A,B,C,D
108291A00108291A001A1-1 -1 -1 A,B,C,D
108301A00108301A001A1-1 -1 -1 A,B,C,D
108311A00108311A001A1-1 -1 -1 A,B,C,D
108321A00108321A001A1-1 -1 -1 A,B,C,D
108331A00108331A001A1-1 -1 -1 A,B,C,D
10834  00-1 -1 -1 -1 0
JGande19
New Contributor

Re: filtering removing all entries

One observation, which might not be relevant, but nevertheless... I have problems with the data initialization in the app creation phase and need often 2 or even 3 attempts for the data initialization.