Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
infock12
Not applicable

%pickmetric doesn't show up in list box

Good morning all!

I have the below load script and it loads all well and I can make charts etc. However, when I try to create a listbox with the inline table (%pickmetric, %metric), I cannot see this option in listbox. I can see in the data model all three tables and there is data island created for the third table and the first two tables connected to each other. Any help is appreciated.

set hideprefix = '%';

TempStaffing:
LOAD Site,
Division,
Directorate,
StaffGroup,
CC as CostCentre,
[CC Description] as CostCentreUnit,
AC as JobNo,
[AC Description] as JobTitle,
pick(match(Period, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12), 'Apr-16', 'May-16', 'Jun-16', 'Jul-16', 'Aug-16', 'Sep-16', 'Oct-16', 'Nov-16', 'Dec-16', 'Jan-17', 'Feb-17', 'Mar-17') as Month,
[Budget wte],
[Actual wte],
Budget,
Actuals,
Category
FROM
…..qvd]

Temporarytable:
LOAD * INLINE [
%pickmetric, %metric
TotalSpend, Actuals
TotalBudget, Budget
]
;

CategoryGrp:
LOAD Category,
CategoryGroup
FROM
[Staffing Mapping Table.xlsx]
(
ooxml, embedded labels, table is Sheet1);

1 Solution

Accepted Solutions
sunny_talwar
Not applicable

Re: %pickmetric doesn't show up in list box

Since you have used hideprefix = '%'; it is a hidden field.... You can find it from the Sheet Properties -> Fields tab -> Make sure to check 'Show System Fields'

Capture.PNG

It will show after the $ fields and before your other regular fields....

4 Replies
sunny_talwar
Not applicable

Re: %pickmetric doesn't show up in list box

Since you have used hideprefix = '%'; it is a hidden field.... You can find it from the Sheet Properties -> Fields tab -> Make sure to check 'Show System Fields'

Capture.PNG

It will show after the $ fields and before your other regular fields....

plu
Not applicable

Re: %pickmetric doesn't show up in list box

Hi Karthik,

You are using set hideprefix = '%'; therefore any field starting with % will not show up in field lists inside the app.

https://help.qlik.com/en-US/sense/3.2/Subsystems/Hub/Content/Scripting/SystemVariables/HidePrefix.ht...

But you can still manually add it if you know it's name to a listbox.

Best regards,

Patrik.

infock12
Not applicable

Re: %pickmetric doesn't show up in list box

Thanks Sunny. Very helpful as always

infock12
Not applicable

Re: %pickmetric doesn't show up in list box

Thanks Patrick. This is useful to know.