Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
Showing results for 
Search instead for 
Did you mean: 

reload license monitor : QVX_UNEXPECTED_END_OF_DATA

I'm on 3.0 server qliksense

when i create a new application inadvertently i have deleted some connections (ArchivedLogFolder, ServerLogFolder, and others).

So when i run License Monitor and Operations Monitor i got error missing that connections. i read in community to restore that using import qvf and publish them.

but now when i run task scheduler to refresh data i got the error : QVX_UNEXPECTED_END_OF_DATA

can you help me ? in attach the log error.

P.S. if i run at hub i have qrs_user/qrs_useraccess lib error

44 Replies

Hi Praveena,

Do you fix the issue?

I have the same error as yours.

If yes, can you provide the solution?

Best Regards,




Am new to Qliksense and the discussion gave me good inputs.

But still please help me to solve with below error (bolded below) that occurred when trying to fetch data using REST Connector.

1. Please provide some inputs of when this usually occurs because am loading three tables using the same rest connection but the last one failed while other first two tables loaded successfully.

2. And how it can be resolved.

2017-03-16 04:29:31 0171 *** CONNECT TO ***

2017-03-16 04:29:32 0173 RestConnectorMasterTable:

2017-03-16 04:29:32 0174 SQL SELECT

2017-03-16 04:29:32 0175 "__KEY_root",

2017-03-16 04:29:32 0176 (SELECT

2017-03-16 04:29:32 0177 "level",

2017-03-16 04:29:32 0178 "metricsCategory",

2017-03-16 04:29:32 0179 "metricsId",

2017-03-16 04:29:32 0180 "metricsName",

2017-03-16 04:29:32 0181 "__FK_metricsLevelList"

2017-03-16 04:29:32 0182 FROM "metricsLevelList" FK "__FK_metricsLevelList")

2017-03-16 04:29:32 0183 FROM JSON (wrap on) "root" PK "__KEY_root"

2017-03-16 04:29:32       7 fields found: level, metricsCategory, metricsId, metricsName, __FK_metricsLevelList, __KEY_root, __extra_,

2017-03-16 04:29:32      Error: QVX_UNEXPECTED_END_OF_DATA: The remote server returned an error: (404) Not Found.

2017-03-16 04:29:32      Execution Failed

2017-03-16 04:29:32      Execution finished.

Thanks in Advance,



Thanks to grangerats resolution to issue #2, I created a new Virtual Proxy (with addition prefix in URL) for processes that cannot use Form Authentication, and

Thanks to sofiene_1920  Linking to Central Proxy.

Now we are able to use Form authentication for our users while keeping the License & Operation Monitors running without issue.


i solve my issue - edit all qrs_* connection change https to http.

I use domain SSL cert to verify https connection for my domain users. And REST connector don't like this.

Contributor II
Contributor II

Hi guys, just upgraded to 3.2.2 (from 3.1.x)

First I was getting errors regarding missing attributes in the archived log files. So I move all of the archived log files (as per some other threads.) Now I'm getting an error like that mentioned here (see snippet below)

I've tried reading through what people have explained above

# We are using default ports for SSL 443

# Our default virtual proxy uses windows authentication

# I don't really understand what is meant by "The account used as the admin during the installation was accidentally removed when the user directory connector updated." But I don't think that is the case with us either

I get that the problem is probably the connector being unable to get access. Is there a way to test just that connection and/or see a better log of what went wrong with it?


2017-04-25 16:07:56 2024 CALL QRS

2017-04-25 16:07:56 2025

  2017-04-25 16:07:56 1031 LET NumRowsQRS = 0

  2017-04-25 16:07:56 1032 SET QRS_RowCounts = 'QRS Row Counts: '

  2017-04-25 16:07:56 1034 For each endpoint in 'qrs_user','qrs_app','qrs_appobject','qrs_task'

  2017-04-25 16:07:56 1035

    2017-04-25 16:07:56 1035 CALL qrs_user

    2017-04-25 16:07:56 1036

      2017-04-25 16:07:56 1057 LIB CONNECT TO ***

      2017-04-25 16:07:57 1059 RestConnectorMasterTable:

      2017-04-25 16:07:57 1060   SQL SELECT

      2017-04-25 16:07:57 1061       "id" AS "id_u2",

      2017-04-25 16:07:57 1062       "createdDate" AS "createdDate_u1",

      2017-04-25 16:07:57 1063       "modifiedDate" AS "modifiedDate_u1",

      2017-04-25 16:07:57 1064       "modifiedByUserName" AS "modifiedByUserName_u1",

      2017-04-25 16:07:57 1065       "userId",

      2017-04-25 16:07:57 1066       "userDirectory",

      2017-04-25 16:07:57 1067        "name" AS "name_u0",

      2017-04-25 16:07:57 1068       "inactive",

      2017-04-25 16:07:57 1069       "removedExternally",

      2017-04-25 16:07:57 1070       "blacklisted",

      2017-04-25 16:07:57 1071       "__KEY_root",

      2017-04-25 16:07:57 1072       (SELECT

      2017-04-25 16:07:57 1073           "@Value" AS "@Value_u0",

      2017-04-25 16:07:57 1074           "__FK_roles"

      2017-04-25 16:07:57 1075       FROM "roles" FK "__FK_roles" ArrayValueAlias "@Value_u0"),

      2017-04-25 16:07:57 1076       (SELECT

      2017-04-25 16:07:57 1077           "id" AS "id_u1",

      2017-04-25 16:07:57 1078           "createdDate" AS "createdDate_u0",

      2017-04-25 16:07:57 1079           "modifiedDate" AS "modifiedDate_u0",

      2017-04-25 16:07:57 1080           "modifiedByUserName" AS "modifiedByUserName_u0",

      2017-04-25 16:07:57 1081           "attributeType",

      2017-04-25 16:07:57 1082           "attributeValue",

      2017-04-25 16:07:57 1083           "externalId",

      2017-04-25 16:07:57 1084           "__FK_attributes"

      2017-04-25 16:07:57 1085       FROM "attributes" FK "__FK_attributes")

      2017-04-25 16:07:57 1086   FROM JSON (wrap on) "root" PK "__KEY_root"

      2017-04-25 16:07:57     22 fields found: @Value_u0, __FK_roles, id_u1, createdDate_u0, modifiedDate_u0, modifiedByUserName_u0, attributeType, attributeValue, externalId, __FK_attributes, id_u2, createdDate_u1, modifiedDate_u1, modifiedByUserName_u1, userId, userDirectory, name_u0, inactive, removedExternally, blacklisted, __KEY_root, __extra_,

      2017-04-25 16:07:57      Error: QVX_UNEXPECTED_END_OF_DATA: Failed to connect to server

      2017-04-25 16:07:57      Execution Failed

      2017-04-25 16:07:57      Execution finished.


The clue to this is either qrs* connections or Virtual Proxy.

Go to QMC Data Connections and check the URL within the connection string.

Go to Virtual Proxy Advanced and entered server name in the white list. More white list needed using HTTPS.

This should work.

Good Luck


The clue to this is either qrs* connections or Virtual Proxy.

Go to QMC Data Connections and check the URL within the connection string.

Go to Virtual Proxy Advanced and entered server name in the white list. More white list needed using HTTPS.

This should work.

Good Luck

Contributor II
Contributor II

Hmm... thanks Calvin. I can't see why it's not working with my existing Virtual Proxy setup (was working before update) but I'll experiment with some options.


Thanks grangerats‌ and sofiene_1920

I've got the second issue after changing the authentication mode of my Qlik Sense server version 3.1SR3.

Your solution using a new virtual proxy has worked



This Worked for me and l also included in the URL connection strings for qrs_* DataConnections an option fo skip SSL selection server certificate verification by using, skipServerCertificateValidation=true;    Also making sure that Qlik Sense Services use a local user with administrative privileges preferably one used for the initial installation of QlikSense. It is important to make sure that the all qrs_* users are set up with appropriate privileges and that the Qlik Sense Service User is not set as inactive, removed externally or blocked in the QMC