Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

cancel
Showing results for 
Search instead for 
Did you mean: 
ricardo_tamagni
Creator
Creator

reload license monitor : QVX_UNEXPECTED_END_OF_DATA

I'm on 3.0 server qliksense

when i create a new application inadvertently i have deleted some connections (ArchivedLogFolder, ServerLogFolder, and others).

So when i run License Monitor and Operations Monitor i got error missing that connections. i read in community to restore that using import qvf and publish them.

but now when i run task scheduler to refresh data i got the error : QVX_UNEXPECTED_END_OF_DATA

can you help me ? in attach the log error.

P.S. if i run at hub i have qrs_user/qrs_useraccess lib error

44 Replies
ricardoprata
Contributor
Contributor

Hello,

Our License Monitor works, however Operations Monitor no.

Operations Monitor runs 3 minutes, does all qrs connections and stop as below.

We have a virtual proxy just for Windows Autentication

Thanks for any help,

Ricardo

     2017-05-16 02:16:09 1254 ENDIF

      2017-05-16 02:16:09 1255

      2017-05-16 02:16:09 1258 *** CONNECT TO ***

      2017-05-16 02:16:10 1260 RestConnectorMasterTable:

      2017-05-16 02:16:10 1261   SQL SELECT

      2017-05-16 02:16:10 1262       "createdDate" AS "createdDate_u1",

      2017-05-16 02:16:10 1263       "modifiedDate" AS "modifiedDate_u1",

      2017-05-16 02:16:10 1264       "modifiedByUserName" AS "modifiedByUserName_u1",

      2017-05-16 02:16:10 1265       "name" AS "name_u2",

      2017-05-16 02:16:10 1266       "enabled" AS "enabled_u2",

      2017-05-16 02:16:10 1267       "eventType",

      2017-05-16 02:16:10 1268       "startDate",

      2017-05-16 02:16:10 1269       "expirationDate",

      2017-05-16 02:16:10 1270       "incrementDescription",

      2017-05-16 02:16:10 1271       "incrementOption",

      2017-05-16 02:16:10 1272       "__KEY_root",

      2017-05-16 02:16:10 1273 

      2017-05-16 02:16:10 1274       (SELECT

      2017-05-16 02:16:10 1275"id" AS "id_u5",

      2017-05-16 02:16:10 1276           "__KEY_compositeRules",

      2017-05-16 02:16:10 1277           "__FK_compositeRules",

      2017-05-16 02:16:10 1278           (SELECT

      2017-05-16 02:16:10 1279               "id" AS "id_u3",

      2017-05-16 02:16:10 1280               "__FK_reloadTask",

      2017-05-16 02:16:10 1281               "__KEY_reloadTask"

      2017-05-16 02:16:10 1282           FROM "reloadTask" PK "__KEY_reloadTask" FK "__FK_reloadTask")

      2017-05-16 02:16:10 1283       FROM "compositeRules" PK "__KEY_compositeRules" FK "__FK_compositeRules"),

      2017-05-16 02:16:10 1284

      2017-05-16 02:16:10 1285       (SELECT

      2017-05-16 02:16:10 1286           "id" AS "id_u10",

      2017-05-16 02:16:10 1287           "__FK_reloadTask_u0",

      2017-05-16 02:16:10 1288           "__KEY_reloadTask_u0"

      2017-05-16 02:16:10 1289       FROM "reloadTask" PK "__KEY_reloadTask_u0" FK "__FK_reloadTask_u0"),

      2017-05-16 02:16:10 1290       (SELECT

      2017-05-16 02:16:10 1291           "id" AS "id_u14",

      2017-05-16 02:16:10 1292           "__FK_userSyncTask",

      2017-05-16 02:16:10 1293           "__KEY_userSyncTask"

      2017-05-16 02:16:10 1294       FROM "userSyncTask" PK "__KEY_userSyncTask" FK "__FK_userSyncTask")

      2017-05-16 02:16:10 1295   FROM JSON (wrap on) "root" PK "__KEY_root"

      2017-05-16 02:16:12      24 fields found: id_u3, __FK_reloadTask, __KEY_reloadTask, id_u5, __KEY_compositeRules, __FK_compositeRules, id_u10, __FK_reloadTask_u0, __KEY_reloadTask_u0, id_u14, __FK_userSyncTask, __KEY_userSyncTask, createdDate_u1, modifiedDate_u1, modifiedByUserName_u1, name_u2, enabled_u2, eventType, startDate, expirationDate, incrementDescription, incrementOption, __KEY_root, __extra_,

      2017-05-16 02:16:12      Error: QVX_UNEXPECTED_END_OF_DATA: DNS error

      2017-05-16 02:16:12      Execution Failed

ricardoprata
Contributor
Contributor

Thanks Granger,

License monitor working.

However Operations Monitor get the error: "System.Net.WebException: The remote name could not be resolved: 'ha'"

Any clue on this?

Ricardo

shraddha_g
Partner
Partner

I tried doing this.. But not m getting error as

QVX_UNEXPECTED_END_OF_DATA: The remote server returned an error: (404) Not Found

Applied settings as below:

1. Changed Https to http in connection string.

2. skipServerCertificateValidation=true;

3. Added new Virtual proxy with Windows Authentication property

What else I will need to do ?

fmarvnnt
Partner
Partner

Possible answer on this article.  Try if it fits with you case.

grangerats
Partner
Partner

FYI:

  After I upgraded to the Qlik Sense June 2017 release, I found that my "License Monitor" and "Operations Monitor" Apps no longer reloaded. There are 8 new Data Connections that need to have their Connection string values updated---for those of us who have customized the server listen port on the default proxy. All of these new Data Connection names start with "monitor_apps_REST_".

  Once I updated them in the same manner that the "qrs_" data connections were, they successfully migrated, and are now working.

HarishG
Partner
Partner

This solution works fine for those who uses 'Windows' as Windows Authentication Pattern. But what if i want to use 'Form' as Authentication pattern?

Can you help me on this?

Thanks & Regards,

Harish G.

calvin_wee
Creator
Creator

Once you are in Form Authentication, everything will be prompt for username and password. This somehow caused the operation monitor to fail (at least I think it is). So to avoid this, we retain the Windows authentication and create a new Virtual Proxy with Form authentications and it works for us. Hope this helps.

db_qliksense
Creator
Creator

Hi All,

I am not able to get solution to my issue.

We recently migrated to Qlik June 2017 (Patch2) single node. Monitoring loads are failing.

Initially, for obsolete user like qrs_*. Moved/imported the newer monitoring apps . this was corrected.

However, load are still not working fine. At the end of the logs, it says data not loaded and to correct the error. Strange thing is I do not see error in the script.

Not sure which log to refer to now.