Qlik Community

Ask a Question

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
QlikWorld Online 2021, May 10-12: Our Free, Virtual, Global Event REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
ioannagr
Creator III
Creator III

show only certain rows in straight table

hello all

I have the following straight table:

dimension,   measure 1, measure 2

I want to show everytime, those rows, when measure 1 and measure 2 are not null .

 

How do i do that please?

 

Thank you 🙂

1 Solution

Accepted Solutions
Kush
MVP
MVP

@ioannagr  you need to put this expression in Dimension,

aggr(if(measure1 >0 and measure2>0, Dimension),Dimension)

and uncheck "Include null values"

View solution in original post

8 Replies
Taoufiq_Zarra
Master II
Master II

@ioannagr  do you have a sample data to see

Regards,
Taoufiq ZARRA

"Please LIKE posts and "Accept as Solution" if the provided solution is helpful "

(you can mark up to 3 "solutions") 😉
Kush
MVP
MVP

@ioannagr  you can create calculated dimension like below

= aggr(if(measure1 >0 and measure2>0, Dimension),Dimension)

Replace measure 1 & measure 2 with actual expressions of measure 1 & measure 2

ioannagr
Creator III
Creator III
Author

@Kush  excuse my ignorance, i've never done this before, where do i put this ?

MayilVahanan

Hi Ioannagr,

In the Dimension tab, you can use the expression given by Kush.

aggr(if(measure1 >0 and measure2>0, Dimension),Dimension)

and "check the suppress when values is Null" checkbox .

Hope it helps

Thanks & Regards,
Mayil Vahanan R
ioannagr
Creator III
Creator III
Author

@MayilVahanan hi, i don't have a suppress when values is null, only include null values which i unchecked!

is it okay?

MayilVahanan

Hi @ioannagr 

Can you provide the sample file to understand better or screenshot?

Thanks & Regards,
Mayil Vahanan R
Kush
MVP
MVP

@ioannagr  you need to put this expression in Dimension,

aggr(if(measure1 >0 and measure2>0, Dimension),Dimension)

and uncheck "Include null values"

View solution in original post

ioannagr
Creator III
Creator III
Author

Thank you all, I just gave @Kush  the solution because of his speedy answer, but thank you guys  lots as well 🙂