Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
rperezlaso
Contributor III
Contributor III

sql server connection ?

hi qlik friends,

have a problem with the connection to sql server.

I have created a user with read permissions. From the qliksense server I do not have access to this bbdd but I do ping the server.

in other servers I have been able to make the connection with the same configuration. Can the error be the firewall or some server configuration?

thanks

1 Solution

Accepted Solutions
rperezlaso
Contributor III
Contributor III
Author

ok works fine with this configuration.

Resultado de imagen de tcp sql port

View solution in original post

6 Replies
jobsonkjoseph
Creator III
Creator III

Hi Ruben,

Would you mind sharing the error which is shown.

Anil_Babu_Samineni

If you can help us to share the error image. We may offer something?

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
rperezlaso
Contributor III
Contributor III
Author

there is no specific error.

I have checked the configuration of

  • SQL SERVER NETWORK CONFIGURATION -> PROTOCOLS FOR SQLEXPRESS -> TCP/IP DISABLED

(Can this configuration be the error?)

in another server the configuration is ( this server work fine 😞


  • SQL SERVER NETWORK CONFIGURATION -> PROTOCOLS FOR SQLEXPRESS -> TCP/IP ENABLED PORT1433

thanks.

chiragp
Contributor
Contributor

Yes, that may potentially be the problem. Also, check if your SQLExpress instance allows remote connections. I think be default SQLExpress does not allow remote connections.

rperezlaso
Contributor III
Contributor III
Author

ok works fine with this configuration.

Resultado de imagen de tcp sql port

View solution in original post

jobsonkjoseph
Creator III
Creator III

So, you just added the port number and enabled it.