Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Announcing the newest addition to the Qlik Community, Qlik Gallery! Learn More
rperezlaso
New Contributor III

sql server connection ?

hi qlik friends,

have a problem with the connection to sql server.

I have created a user with read permissions. From the qliksense server I do not have access to this bbdd but I do ping the server.

in other servers I have been able to make the connection with the same configuration. Can the error be the firewall or some server configuration?

thanks

1 Solution

Accepted Solutions
rperezlaso
New Contributor III

Re: sql server connection ?

ok works fine with this configuration.

Resultado de imagen de tcp sql port

6 Replies
Highlighted
jobsonkjoseph
Contributor III

Re: sql server connection ?

Hi Ruben,

Would you mind sharing the error which is shown.

Re: sql server connection ?

If you can help us to share the error image. We may offer something?

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
rperezlaso
New Contributor III

Re: sql server connection ?

there is no specific error.

I have checked the configuration of

  • SQL SERVER NETWORK CONFIGURATION -> PROTOCOLS FOR SQLEXPRESS -> TCP/IP DISABLED

(Can this configuration be the error?)

in another server the configuration is ( this server work fine 😞


  • SQL SERVER NETWORK CONFIGURATION -> PROTOCOLS FOR SQLEXPRESS -> TCP/IP ENABLED PORT1433

thanks.

chiragp
New Contributor

Re: sql server connection ?

Yes, that may potentially be the problem. Also, check if your SQLExpress instance allows remote connections. I think be default SQLExpress does not allow remote connections.

rperezlaso
New Contributor III

Re: sql server connection ?

ok works fine with this configuration.

Resultado de imagen de tcp sql port

jobsonkjoseph
Contributor III

Re: sql server connection ?

So, you just added the port number and enabled it.