Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Not applicable

Re: Always one selected value how to enabled?

thanks both, my bad, i didn't read carefully. it works.

Not applicable

Re: Always one selected value how to enabled?

AFTER selecting one value on the list box, option is still not available. would you know why?

I am using the latest version of QV.

Highlighted

Re: Always one selected value how to enabled?

 

Hi Siva, I had the same problem, maybe this example can help you.

 

If you use an expression instead of a field when you set the "List Box", the "Always one selected value" property is always disabled.

Excuseme for my bad english.

Osvaldo Macoritto
SKI Tecnología
Arjunarao
Honored Contributor II

Re: Always one selected value how to enabled?

Hi ,

You can't clear the selected value untill you un-select the option.

Try and Apply > OK like as shown in screen. Hope this will help you.

Capture.PNG

maxime66
Contributor

Re: Always one selected value how to enabled?

Hi jagan,

could you please expalin your solution ?

thanx.

Not applicable

Re: Always one selected value how to enabled?

hi,

in list box first select one value

after to go properties  ''Always one selected value" ie enable

you selet check box

then apply

if you click on  clear button that value is never errase

Not applicable

Re: Always one selected value how to enabled?

Hi Jagan can you please explain how you did it?

Partner
Partner

Re: Always one selected value how to enabled?

Hi Arif,  to do this you just need to make a selection in a list box and then right click and go into properties, then tick 'Always one selected value' in the general tab

Not applicable

Re: Always one selected value how to enabled?

Hi Chris

thanks for reply. But it works only on field data into listbox and not working when data from expression in Listbox.

Thanks again.

delroekid
Contributor

Re: Always one selected value how to enabled?

this will now work if the listbox is an expression.