Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Highlighted
davidsimpson
Contributor

Bookmarks don't save in web view

Hi QlikView community can anyone help me? I can't get bookmarks to save in AJAX - I'm on version 9 of QlikView. It appears that they will save but then nothing happens. I need users to be able to view QV via the web and save their own local bookmarks specific to their needs. Bookmarks will save ok in the App when I work on the server version but they then appear for all users and I don't want to administer everyones needs for bookmarks centrally.

Any ideas?

Thanks in advance.

David

1 Solution

Accepted Solutions
Not applicable

Bookmarks don't save in web view

Hi David,

Are you using small business edition by any chance as collaboration is not allowed with this version. Bookmarks come under the guise of collaboration. The option to create them still shows when you open through a browser but when you create a bookmark nothing happens.

Kind Regards,
Footsie

View solution in original post

7 Replies
vgutkovsky
Honored Contributor II

Bookmarks don't save in web view

How are they not working, they're not saving selections or they're not saving layout? Also, are you on SR7?

Regards,

davidsimpson
Contributor

Bookmarks don't save in web view

Hi Vlad, the bookmarks appear to "work" in that the box appears for Add Bookmark and I can enter details name and info text but when I click ok and the box goes there is no saved bookmark in the application - it's like I didn't do anything. I'm hoping there's a setting somewhere I don't know about.

Your Help is appreciated.

Regards

David

vgutkovsky
Honored Contributor II

Bookmarks don't save in web view

Are you using anonymous authentication by any chance? Also, is this problem happening from all user computers? If so, is it happening through all browsers (IE and FF)?

Not applicable

Bookmarks don't save in web view

Hi David,

Are you using small business edition by any chance as collaboration is not allowed with this version. Bookmarks come under the guise of collaboration. The option to create them still shows when you open through a browser but when you create a bookmark nothing happens.

Kind Regards,
Footsie

View solution in original post

davidsimpson
Contributor

Bookmarks don't save in web view

Hi Footsie, Vlad. Yes I am using small business edition just 10 Users and 50 CALS so far. I didn't realise that the edition would have an impact on something like Bookmarks. Great news to know that the issue is bigger than my lack of understanding but still a problem for me to sort out. Users all want their own favourites as you can imagine.

Thanks for your help guys - I'll have a think now about another way to fix the issue.

Regards

David

johanfo2
Contributor

Bookmarks don't save in web view

Is this correct?  I was on Version 10 SP3 Small Business Server, and here bookmarks worked just fine.  Now, on Version 10 SP4 and running through IIS, bookmarks does not work anymore!

Any guess of why this is happening?

johanfo2
Contributor

Bookmarks don't save in web view

Problem solved.  Seemed to be a bug in v10 SP4.  After I received a custom patch from QlikTech, everything was back to good.