Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Can't open app/strange server object

Hi!
We have a problem with one of our apps, it sometimes won't open. When this happens it applies to all users. The client (fullversion and web) does not respond and must be terminated manually.
When this happens and if you try to open it again and again the number of sessions increases by one each time (showing in the Management Console). The app then only opens if I open it in design mode on server, or copy it from server to local machine.

When using the QlikView Mangement Console, chosing this Document/app and Server Objects, one of the Server Objects is strange. The Id is "Server\", the Type displays "Invalid: Meta Content" and the Sub Type displays "Unknown". The "Owner" field is empty (watch picture). I am able to delete this object, but the object returns immediately. Have tried to move/delete the .shared file (can't do that when the problem occurs) but if I move it, the Server Objects for all users will disappear.

I do not know if there is a direct connection between this, but it is natural to assume that.

Anyone know what to do?

We run QV11 Small Business Edition

5 Replies
gonzaloruizgonz
Contributor

Re: Can't open app/strange server object

i have the same problem, i have try to defrag the share file but the problem persist.

//Gonza

Not applicable

Re: Can't open app/strange server object

Hi, in the Management Console on the document, I removed the possibility for the users to "Allow Creation of Server Objects".

Don't know if that is the answer, but after doing so, the problem has not occured again.

gonzaloruizgonz
Contributor

Re: Can't open app/strange server object

I can not do that because this user use qlikview server object a lot of. I have put back the old Share file and is work now, but a possibility is also to the defrag the corrupt share file one more time..

julian_rodrigue
Valued Contributor

Re: Can't open app/strange server object

Hello, I have the same problem, and the users are getting the error message "Session Lost" when loading the document. I should restart the Qlikview Services to solve it, but it is not the final resolution.

Any ideas?

Thanks

gonzaloruizgonz
Contributor

Re: Can't open app/strange server object

HI,

Is probably related to the share file, i have now upgrade to 11.20 sr5 and to be honest all problems i had with instability caused by share files are now fixed.

To defrag the share file not helped me, in this case i was forced to put back an old backup of the share file. After that everything become normal again.

BR//Gonza