Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
The #1 reason QlikView customers adopt Qlik Sense is a desire for a modern BI experience. Read More
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Creator III
Creator III

Data

Hi All ,

PLease find the attachment of QVW file and as well as sample data ,

In the excel all the data under field start with some '"" or ;; this kind of symbols

I want to know how do i remove this thing at the script level and fetch only the data ..

Ragrds

1 Solution

Accepted Solutions
Highlighted

Re: Data

You have one parameter too much. Use

Replace(Name,   ','  ,  ' ' ) as Name


But you can use Subfield also if you only have one field as Name.


HIC

View solution in original post

6 Replies
Highlighted

Re: Data

PurgeChar(Serial, ';') as Serial,

PurgeChar(Petent, '*') as Petent,

PurgeChar(Name, chr(39)) as Name

HIC

Highlighted
Creator III
Creator III

Re: Data

Thanks Henrics

It worked , one more question related to the same  file is that

i have a field name  as NAME under which the maes are separeted by comma that is

Luke,Right

Michael,brave

In qlikview i want to display like below, i want to take out the comma ,

Luke Right

Michael brave

Thanks in advance

Highlighted

Re: Data

You can use

Replace(Name, ',', ' ') as Name

or

Subfield(Name,',',1) & ' ' & Subfield(Name, ',', 2) as Name

HIC

Highlighted
Creator III
Creator III

Re: Data

Hi Henrci

I have only one field as name so what iam trying to do is

Replace(Name, ',', ' ',ch(39)) as Name


which is showing an error


Thanks

Highlighted

Re: Data

You have one parameter too much. Use

Replace(Name,   ','  ,  ' ' ) as Name


But you can use Subfield also if you only have one field as Name.


HIC

View solution in original post

Highlighted
Creator III
Creator III

Re: Data

Ok Thanks

I understood it we use  Subfield(Name,',',1) & ' ' & Subfield(Name, ',', 2) as Name

to maintain the space after comma