Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

ellyodelly
Contributor

Date is loading wrong when I change the alias


I am loading data from a QVD- it has a creation date , then I load the date again with an alias and it appears wrong. I have done this a number of time before not sure what I did wrong this time..   day and year appear to be ok- but month is wrong.

please view attached.

1 Solution

Accepted Solutions

Re: Date is loading wrong when I change the alias

It seems to me as if the qvd has been created with an incorrect format code, e.g. mm/dd/yyyy instead of MM/DD/YYYY. Note that the format is case sensitive and that m means minutes and M means months.

HIC

View solution in original post

3 Replies

Re: Date is loading wrong when I change the alias

It seems to me as if the qvd has been created with an incorrect format code, e.g. mm/dd/yyyy instead of MM/DD/YYYY. Note that the format is case sensitive and that m means minutes and M means months.

HIC

View solution in original post

chiru_thota
Valued Contributor

Re: Date is loading wrong when I change the alias

Can you try below while loading data ?

Load

round((Timestamp([SO Order Date],'MM/DD/YYYY') as tod,

round((Timestamp([SO Order Date],'MM/DD/YYYY hh.mm.ss') as [Calendar Date]

...

ellyodelly
Contributor

Re: Date is loading wrong when I change the alias

thanks!  I forgot about the case sensitive... will have to go back and recheck all of my QVD creation files.  always a day to learn!