Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Dimension/SortOrder getting displayed in Current selection

Hi friends:

I am using a SortOrder field to Sort my dimensions.

I am using a Straight table and using SortOder field as a dimension.

I sort my table on this SortOrder field but hide it by using "Hide column" in the presentation.

This sortOrder does not show up in the table but when a user click on any data item in the chart ,

this field shows up in the current selection along with other items.

How can i hide this so that it does not appear in the current selection.

Thanks.

6 Replies
Not applicable

Re: Dimension/SortOrder getting displayed in Current selection

You can order any field by an expression, without needing to show the field in the table.

JG

Gabriel
Not applicable

Re: Dimension/SortOrder getting displayed in Current selection

Hi,

I will use ~ after the filed name in the script

Regards,

Gabriel

Not applicable

Re: Dimension/SortOrder getting displayed in Current selection

Juan:

Thanks for your response.

I have to sort the dimensions and not sure how i can sort in the expression.

But i was able to clear out sort order from the current selection by using a macro.

Not applicable

Re: Dimension/SortOrder getting displayed in Current selection

Gabriel:

Thanks for your response.

I used ~ after my field in the script but it did not work out.

It still showed sort order field in the current selection.

But i was able to clear out sort order from the current selection by using a macro.

Not applicable

Re: Dimension/SortOrder getting displayed in Current selection

You can use the order by expression, in the Sort tab:

Capture.PNG

JG

Gabriel
Not applicable

Re: Dimension/SortOrder getting displayed in Current selection

Hi Chad,

I don't know if you have fixed this issue. I just remember that you have to define

Hideprefix

SET Hideprefix ='~';

then

LOAD Sort order AS [~Sort Order];

Then the rest of your script follow

Click ok

If you also want to hide the field completely, go to USER PREFERENCES (alt+ctrl+U) then uncheck Show system field

Click OK

Hope this helps

Regards,

Gabriel