Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Not applicable

Displaying values in units of 000s, 000,000s, etc.

In the QlikView main tutorial, under the section "Creating a bar chart using the full chart wizard" (p69), it describes changing the number format by altering the [Number]: [Thousand Symbol] option, When I enter a value for [Thousand Symbol], I get the axis labels in terms of 000s, but the individual bar value labels remain in their original format. How can I get the values displayed to be in terms of 000s or other unit?

I know I could accomplish this by altering the Expressions parameters to simply divide everything by 1000, but the way the tutorial reads, it seems to suggest that it could be done automatically using Number formatting options.


Tags (4)
2 Replies
Valued Contributor III

Displaying values in units of 000s, 000,000s, etc.

Not applicable

Displaying values in units of 000s, 000,000s, etc.

Thank you for replying, but that thread simply reiterates what I already posted originally - that a semi-workaround is to modify the Expression value to divide the figure by the denomination.

The problem is that the Symbol notations are applied inconsistently. This makes maintenance of and changes to charts more frustrating. For example, suppose I work with the total sales per country chart from the tutorial. I put "K" into the Thousand Symbol box, indicating i want my figures in 000s. I get this:


So ok, to fix this, I change the expression from Sum(Sales) to Sum(Sales)/1000. I get this:


...which is fine, it's what I want, although I had to apply some minor elbow grease. But what if I wanted to change it over to a pie chart? I switch the option in the General tab to pie chart, and enable Show Numbers in Legend. I get this:


So now, in contrast to the bar chart, where Qlikview applied the symbol notation only on the axis scale, for the pie chart, it DOES apply it to (some) of the marked values. In this case, the symbol notation is applied to the legend numbers, but not the pie chart numbers.

This is easy to fix, all I have to do is remove the Thousand Symbol value, and change the title to say "...(in 000,000s)".

But just because there's a workaround to it, doesn't mean the behavior makes any sense. Please let me know if I'm missing something.

Community Browser