Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Leverage your QlikView investment to modernize BI – see how! Join Group
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor II
Contributor II

Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Olá Pessoal,

Estou com um erro muito estranho em minha máquina. Eu tinha vários arquivos Qlikview e eles começaram a dar um erro quando tentava abrir.

Achando muito estanho pois não troquei nem de maquina nem de versão de Qlickview resolvi criar um novo arquivo com a carga de um simples CSV.  O erro é exatamente o mesmo. Eu crio um arquivo novo do zero. Independente do que eu faça no arquivo eu não consigo abri-lo novamente após fecha-lo.

Até salvar um aquivo QVD em branco e depois tentar abrir novamente (na mesma máquina) ele acusa o erro "A carga do documento  (mostra o caminho do arquivo e nome do arquivo) falhou".

Clicando no botão OK ele retorna com a mensagem "Failed to open document". Importante resalvar que nao estou tentando abrir nenhum arquivo criado em outra máquina e nem em outra versao de Qlikview. 

Estou com  Qlikview April 2019 SR1 versão 12.40.20100.0
Windows 10



Conto com vocês!

Guilherme Duarte

10 Replies
Highlighted
Contributor
Contributor

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Olá,

Tudo certo?

Tenta fazer o seguinte, abra o qlikview sem carregar nada. Clique sobre o menu Ajuda, Vá em Sobre o Qlikview.

Após isso, terá o ícone da Qlik no canto inferior esquerdo da nova janela aberta. Clique com botão direito nele e Procure por Application Rescue, passe o valor para 1 e tente abrir um dos qvw não estavam carregando.

Highlighted
Contributor II
Contributor II

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Gustavo, primeiramente obrigado pela ajuda.

Fiz o procedimento informado por você e substitui o parâmetro "0" por "1" conforme instruções mas não funcionou. 

Fechei o Qlikview e abri novamente, tentei abrir algum arquivo anterior. O Erro continua. Criei um arquivo novo totalmente em branco com o parâmetro 1. Salvei fechei e tentei abrir o arquivo. O erro continua...

Alguma idéia do que possa estar acontecendo?

Guilherme Duarte

Highlighted
Contributor
Contributor

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Infelizmente... Não sei o que pode estar ocorrendo. Eu diria pra reinstalar o Qlikview para ver se irá corrigir o problema

Highlighted
Contributor II
Contributor II

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Gustavo.

Acabei de fazer isto. Baixei e reinstalei o programa (fiz hoje pela manhã). Continuo com o mesmo erro. 
Parece que fica alguma coisa no registro pois ele aparece a relação de ultima arquivos abertos da ultima instalação. Então deve estar buscando algo alem disto.

O mais estranho é que tudo funcionava perfeitamente. Meus painéis estão todos ok.
De uma hora para outra, deu o erro. Assim, perdi o acesso a todos os painéis já criados.

Fiz o vídeo em anexo com a nova instalação.

Guilherme


Highlighted
Contributor
Contributor

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Olá,

O usuário é adm? Tenta criar um novo usuário de ADM, mesmo o seu já sendo só pra ter certeza que eliminamos tudo.

Outra coisa, cria uma nova pasta, e libera na aba segurança acesso de controle total para "Todos".

Tenta salvar ali dentro

 

Gustavo

Highlighted
Contributor II
Contributor II

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Gustavo ,

Meu usuário é Admin.  Criei uma nova pasta, permissão total para a pasta. Mesmo erro.

Criei um novo usuário Admin na mesma máquina. Abri o Qlikview e ele apresentou a mensagem que é a primeira vez que estava executando e que todos os arquivos seriam marcados para este novo perfil. Salvei um arquivo em branco. O arquivo abriu.  🙂

Realmente Gustavo, por estar acostumado com meu usuário ser ADMIN, não pensei em fazer este teste, criar um outro usuário windows admin. 

Então,  ao que indica, a questão e de permissão ao meu usuário Admin (criado na instalação do Win10).  

Observando as variáveis do meu usuário (com erro) e com o usuário teste identifiquei os seguintes parâmetros com valores diferenciados (seguindo as suas instruções na primeira resposta). 

AcceptEULA,no
InstalledLIBID110,
SavedCustomColors,
Utf8FileDlgPathOpenDoc,
Utf8FileDlgPathSaveDoc,C:\Users\Perícia\Documents
DontShowConfirmAbort,-1
DontShowConfirmRemoveMutipleObjects,-1
DontShowConfirmRemoveObject,-1
DontShowConfirmToShowStartPageAgain,-1
FirstUserExperience,1
HatchedBrushes,1
KeepProgressOpen,0
SelectionPosition,2
ShowStartPageOnStartup,1
_CacheLoginInfo,1



Fiz as alterações no meu usuário mantendo o padrão acima. Não funcionou.

Então, pode ser alguma permissão do meu usuário. Alguma sugestão de onde olhar, o que olhar?

Highlighted
Contributor
Contributor

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Olá Guilherme,

Então... Agora essa parte de configuração de usuário foge um pouco do meu conhecimento, não conheço tão bem essa parte. Mas, eu diria pra olhar as preferências do Usuário dentro do Qlikview e ir comparando as opções, vai dar trabalho, porém, não sei em qual local olhar diretamente...

Highlighted
Contributor II
Contributor II

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Gustavo, agradeço a sua atenção e já foi válida as tratativas.

O problema ainda continua e estou pesquisando aqui. Qualquer solução será publicada. Se alguém da comunidade tiver mais alguma sugestão.

Guilherme 

Highlighted
Contributor
Contributor

Re: Erro ao abrir novo arquivo QVD (mesmo arquivo novo e em branco)

Olá @Guilherme! Estou com o mesmo problema em minha máquina do servidor. Estava tudo rodando certinho mas agora parou de funcionar e só dá o erro ao carregar o documento como vc bem descreveu.

Já tentei mudar o Application Rescue, renomear o arquivo, mudar de local, remover uma tabela grande para diminuir o tamanho do documento, mas nada deu certo.

Você chegou a mexer nas configurações do usuário Admin?

Abraço!